Windows 10: UAC doesn't work for Windows Defender

  1.    21 Jul 2017 #1

    UAC doesn't work for Windows Defender


    Hi guys,

    I am trying to temporarily disable my Windows Defender, and whenever I click on one of the two Off buttons I need, it does the UAC thing where it asks if I want to continue. Unfortunately, even if I click Yes, the button turns to Off for a split second before going right back to On. What's happening?
      My ComputerSystem Spec

  2.    22 Jul 2017 #2

    Hey bluegreenturtle,
    Windows Defender Real Time Protection is designed to turn itself back on, but I haven't seen it do so immediately.
    What version of Win10 are your running ? (WinKey + r, type winver)
    What two buttons are you referring to ? (A screen shot would be nice)

    Edit: Had commands backwards .. fixed now
    You can try the following, to turn Off/On Real Time Protection.
    Open PowerShell as Admin
    (Turn Off)
    Set-MpPreference -DisableRealtimeMonitoring $true
    (Turn On)
    Set-MpPreference -DisableRealtimeMonitoring $false
    Last edited by Eagle51; 22 Jul 2017 at 19:58.
      My ComputersSystem Spec

  3.    22 Jul 2017 #3

    I tried it in Powershell like you showed. The command was accepted but nothing actually changed. I'm using version 1703 Windows Home. Here is what it looks like (I need to turn off both protections):

    https://imgur.com/gallery/WdLOm
      My ComputerSystem Spec

  4.    22 Jul 2017 #4

    Sorry about that, I got them backwards...

    Open PowerShell as Admin
    (Turn Off)
    Set-MpPreference -DisableRealtimeMonitoring $true
    (Turn On)
    Set-MpPreference -DisableRealtimeMonitoring $false

    Once you Disable Real Time Protection, I don't think you need worry about Cloud Protection.
      My ComputersSystem Spec

  5.    22 Jul 2017 #5

    Still no

    https://imgur.com/gallery/kvxE1

    It actually won't let me add an exclusion either, although it did allow me turn off other sections like "Check apps and files."
    Last edited by bluegreenturtle; 22 Jul 2017 at 20:58. Reason: More information
      My ComputerSystem Spec

  6.    22 Jul 2017 #6

    Hmmm... Looking at your last screen shot there's no space between the commands., it's all run together.
    Set-MpPreference (spacebar) -DisableRealtimeMonitoring (spacebar) $true
      My ComputersSystem Spec

  7.    22 Jul 2017 #7

    I did that and it said I don't have enough permissions. I double checked and all of the admin stuff is just fine. (I'm the only user anyway.)
      My ComputerSystem Spec

  •    22 Jul 2017 #8

    You sure you ran PowerShell as Administrator ?

    WinKey + s, type in powershell, right click on PowerShell in list and Run as Administrator.
      My ComputersSystem Spec


  • Posts : 3,150
    10.5 Home 1803 x64
       23 Jul 2017 #9

    Turn On or Off Windows Defender in Windows 10 Windows 10 Security System Tutorials

    Run "Disable WD.bat" as admin and restart (run again after restart to disable its services if needed).

    Run "Enable WD.bat" as admin and restart to get it back to business.
    UAC doesn't work for Windows Defender Attached Files
      My ComputerSystem Spec


  • Posts : 5
    Windows 10 creator edition
       27 Jul 2017 #10

    Run a virus that disables it! (Jk)
    Try typing UAC in cortana, then click change user account control settings and switch it to never notify, then try disabling Windows Defender
    (You can switch it back to always notify after defender is off)
      My ComputerSystem Spec


  •  

    Related Threads
    I bought a new Dell Laptop with Windows Ten Home. I wanted to wipe the laptop clean and set it up the way I set up all my machines, partitioning the drive basically. Plus to wipe out whatever crap they pre-install. The product key for the OS it...
    Disc drive doesn't work on Windows 10 in Drivers and Hardware
    I upgraded from Windows 7 to Windows 10 a few months ago. Yesterday the disc drive stopped working. I put in a disc I had made which contained various data, mostly text. When I clicked the D recovery drive nothing happened. In the past I would...
    Scrolling inactive windows doesn't work in Installation and Upgrade
    Hello! I have installed the Win 10 enterprise LTSB the trial version. So far, so good, with the exception of two details: - The scrolling of inactive windows isn't working properly. I mean, it works only when the "Settings" window is the active,...
    Password from windows 7 doesn't work on 10 in User Accounts and Family Safety
    I have a password that contained ctrl+backspace in the series, but when I upgraded from windows 7 to 10 that character was no longer supported. I can not log in or change my password now. Any idea how to either revert back to 7 to change it, or...
    Windows 10 Search doesn't work in General Support
    Hi there The Search doesn't work properly whether done via Brink's method (using the Charms and getting the search bar up) or searching using the menu search. (You can use file explorer but if I just want to find a file I shouldn't have to use...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 21:05.
    Find Us