1.    12 Apr 2017 #1
    Join Date : Aug 2015
    Posts : 52
    Windows 10

    defender issues after creator update


    i got an 'unknown usb device (set address failed)', which was noticed when I checked defender...
    I also cannot enable the defender threat service... clicking restart does nothing.

    i uninstalled the device and restarted, but didn't fix it, altho the WSC icon shows 'no actions needed' now. Tried to update driver but it was good. Quick Scan won't run. I have Malwarebytes free installed but not active.

    ideas? got this on inspecting the event: Device USB\VID_0000&PID_0004\6&cc8d8ff&0&2 was migrated.
      My ComputerSystem Spec
  2.    12 Apr 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,970
    Windows 10 Pro Build 1703

    Hi maarkr

    First off I would uninstall Malwarebytes. For testing. I know you said it is not doing real time protection buyt give it a try.

    Once uninstalled, restart. See how or if behaviour changes.


    Ken
      My ComputerSystem Spec
  3.    12 Apr 2017 #3
    Join Date : Aug 2015
    Posts : 52
    Windows 10
    Thread Starter

    uninstalled, no change
      My ComputerSystem Spec
  4.    13 Apr 2017 #4
    Join Date : Oct 2013
    Covington, Louisiana
    Posts : 730
    Windows 10 1703 Pro 64

    New Component Package 1.0.103 released today to fix problem with MB 3 disables Windows Defender in Creators Update.

    The initial workaround was to set MB 3 option for Windows Action Center to never.

    CP update will be pushed through MB updates.

    Check the Action Center to see if MB is still listed?
    Did you try a restart after removing MB.



    Jim
    Attached Thumbnails Attached Thumbnails MB Action Center.JPG  
      My ComputerSystem Spec
  5.    13 Apr 2017 #5
    Join Date : Aug 2015
    Posts : 52
    Windows 10
    Thread Starter

    MB completely uninstalled with third party uninstaller and restarted.
    Virus and Threat Protection in WDSC greyed out.
      My ComputerSystem Spec
  6.    13 Apr 2017 #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,970
    Windows 10 Pro Build 1703

    Have a look at this. Sounds like Defender was disabled my Malwarebytes and it is not acknowledging that it was removed.

    http://www.pcadvisor.co.uk/how-to/wi...ws-10-3466684/
      My ComputerSystem Spec
  7.    13 Apr 2017 #7
    Join Date : Aug 2015
    Posts : 52
    Windows 10
    Thread Starter

    please, I've been thru every process and service and NO av products are running, nor was MB active when I updated to Win10 CU. I only ran it to perform a monthly check for malware. It is completely uninstalled.

    The WDSC says my device is being protected, but Virus and Threat Protection is x's out and the Restart button is greyed out. Firewall and App icons are OK. In the Virus tab, Scan History shows no threats found, yet quick scan is grey, and when clicked, it says QS running, but no time elapsed and 0 files scanned. Real time and cloud based protection is enabled, but I cannot enable Auto Sample Submission.
      My ComputerSystem Spec
  8.    13 Apr 2017 #8
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,970
    Windows 10 Pro Build 1703

    I agree but what I think has happened is Malwarebytes corrupted something. It was installed and now that it has been removed Defender isn't acknowledging that it has been removed.

    I wonder if this wouldn't be the time to run a repair / in place upgrade to repair the installation.

    Repair Install Windows 10 with an In-place Upgrade

    I would have my data files backed up, just in case.

    Ken
      My ComputerSystem Spec
  9.    13 Apr 2017 #9
    Join Date : Oct 2013
    Covington, Louisiana
    Posts : 730
    Windows 10 1703 Pro 64

    1. You may want to try MB-Clean tool and see it that helps.

      https://forums.malwarebytes.com/topi...mb-clean-tool/

      Latest version is 2.4.1.1015.

      Recommended procedure:

      Download the latest version of MB-CLEAN by clicking the link above
    2. Close all open applications
    3. Double-click and run mb-clean.exe


    1. A prompt with an option to clean up the system will appear:
    2. Yes - will proceed with backing up the license key (Malwarebytes 3.x only) and initiating the cleanup process


    • No - will exit the utility



    1. Once the cleanup process is completed, a prompt will appear:
    2. Yes will proceed and post reboot you will be prompted to continue with the downloading, installation and activation of latest version of Malwarebytes 3.x


    • No will exit the utility and you will not be prompted (post reboot) to download, reinstall and re-activate (not recommended)
      • We recommend rebooting immediately. Additionally, stopping at this step is not recommended and will most likely not resolve your issue(s).



    1. Upon reboot, a prompt will appear:
    2. Yes - will download, install and activate the latest version of Malwarebytes 3.x


    • No - will exit the utility and the cleanup process is complete
      • Choose this option if you do not want to download, install and activate the latest version of Malwarebytes 3.x


    • A log file ("mb-clean-results.txt") will be on your desktop
      My ComputerSystem Spec
  10.    14 Apr 2017 #10
    Join Date : Aug 2015
    Posts : 52
    Windows 10
    Thread Starter

    thanks for the ideas but I never thought it had to do with the MB.

    after a hard restart, I got a message saying that WD was disabled by group policy. Logged into the gpedit.msc thru cmd prompt admin, and found a setting that turned off WD... disabled it and voila~! WD works, I can scan, etc.

    I still have the issue with a bad usb device that I'm trying to trace.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Small issue after upgrading to creator's update
So I just have this error in the event viewer ever since I upgraded to win 10 creators update. Event 7000 Service Control Manager The CldFlt service failed to start due to the following error: The request is not supported. Any idea what...
Performance & Maintenance
Solved After Creator Update Conflict Between Malwarebytes & Windows Defender
I installed the Creator Update yesterday. Today I noticed Defender didn't update definitions. I opened the Security Center, and it's reading my installed Malwarebytes 3 Premium as "..other antivirus provider.." 129636129637 Before the update, I...
AntiVirus, Firewalls and System Security
Changing system fonts in Creator Update
In Creator Update build, ability to change system fonts was removed from desktops settings. One possible solution was Winaero tweaking utility, now Wintools released another utility, called System Font Size Changer which is small and portable. ...
Customization
Solved Creator update AC notifications broke?
So I had VM creator that update went fine with, so i put on real hw they update didnt go well start menu was pretty much lost all installed programs from the list and nothing could be pinned to the start menu, reinstalling programs didnt fix the...
Windows Insider
Creator update issues
I had original installed creator update in VM and the update went fine. So i did an install on actual hardware the update didn't go fine. Upon first boot up I noticed all the icons i had pinned on startmenu were corrupt, so I rebooted system when...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums