Having just cleanly installed April (2018) Update, I'm kinda loathe to install 3.5.1 - the 3.5 ßeta kept throwing build 17661 into GSODs (failure on mwac.sys, a part of MB 3.x) whenever I scrolled through images in my Pictures folder or was watching videos online.

But, I can't stand not being protected, so....

Here goes nothing....