I'm trying to update Windows Defender virus definitions. The update proceeds quickly up to about 40% complete, but still in the "Searching . . . " phase (according to the green progress bar), and then just hangs. Forever. I waited several hours and still no movement, and no disk activity.

I searched online and found a way (supposedly) to manually update Windows Defender. I downloaded a file called mpas-fe.exe from here ( https://support.microsoft.com/en-us/kb/923159 ), but when I tried to run it (as Administrator), I saw the little spinning wheel for a few seconds and then nothing. Nothing. No error message, no log file entry (that I could find), no process running in Task Manager. Nothing.

I rebooted in Safe Mode and tried running mpas-fe.exe again, but got the same result. The program seemingly starts to run for a few seconds and then just disappears. I've seen this kind of thing happen before when there is some sort of corruption, either with the system file(s) or the executable file itself. It is a pet peeve of mine that MS provides no clue whatsoever when this happens. In the past, I've tried using the DISM utility with mixed results. Even in the best case it is very awkward to work with and documentation is sporadic around the internet.

I don't think I have any malware on my system. I ran MalwareBytes and it came back clean. I do not visit any porn or gaming sites, and I never download anything the slightest bit suspicious. I am very careful and I rarely acquire anything close to malware on my system.

Any help anyone can provide would be greatly appreciated. Thank you.