Windows Firewall -- can't access WINDOWS from LINUX

  1. Posts : 11,246
    Windows / Linux : Arch Linux

    Windows Firewall -- can't access WINDOWS from LINUX

    Hi there

    Not sure but the wretched built in firewall on W10 seems to stop my Linux server accessing Windows shares even when the firewall is turned OFF.

    The Windows box can access the Linux shares so something is hosed up here again. I've enabled remote access etc but it still doesn't work. I've also switched off the SERVER's firewall too for testing.

    Re-booted the Linux server (Never need to do that normally) and Windows but still no joy.

    LINUX==>WINDOWS - Fail

    Windows networking isn't the best I know but this type of stuff should be basic to any modern OS - so I can't play my music streamer on Windows currently !!

    Attached Thumbnails Attached Thumbnails Windows Firewall -- can't access WINDOWS from LINUX-linux.png  
    Last edited by jimbo45; 03 Oct 2014 at 06:41.
      My Computer

  2. Posts : 116

    Jimbo, any luck?

    I have no problem accessing Windows 10 drive and folders when using ZorinOS 9 (based on Ubuntu).

    Windows Firewall -- can't access WINDOWS from LINUX-win7folders-zorinoslinux.png

      My Computer

  3. Posts : 25
    Windows 10

    @GEWB, what flavor (version) of Samba is delivered in that distribution? That might be the difference in why it works for you and not me and others. I'm using Fedora 20 and CentOS 6.5 which came with Samba 3.x. Neither Linux machine on these distributions can access Windows 10 shares.
      My Computer

  4. Posts : 11,246
    Windows / Linux : Arch Linux
    Thread Starter

    Hi there

    I think the answer is to re-enable the file wall and BLOCK Port 139 --then Magic it all works again. Older versions of SAMBA / Windows like Windows 7 use TWO ports 139 and 445 for remote access -- Windows 10 now only uses port 445 so older systems fail since they try port 139 first which fails - then returns FAIL to the remote software (SMB server etc). Blocking Port 139 ensures that Port 449 is tried and that reports SUCCESS. Strange but firewall ON fixes the problem --normally switching firewall OFF cures these types of things.

    (Note Block the port in the Windows 10 firewall not the Linux / W7 Firewalls !!!).

      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:44.
Find Us

Windows 10 Forums