What in the firewall is blocking my app?

  1. Posts : 55
    Windows 10 Anniversary (Pro)

    What in the firewall is blocking my app? UPDATE

    Here's some background.

    Win 10 Version 19041
    I do a lot of Arduino programming and a lot of my projects utilise a feature called OTA (Over the Air program uploads over WiFi).. Sometime in the past few weeks the OTA uploads stopped working. I downloaded the Arduino IDE program to another desktop PC and to a Windows tablet. OTA works fine from those two platforms. On the problem PC, I can get the OTA feature to work if turn off the public firewall. So, my conclusion is that the firewall is blocking something that this feature needs.

    How can I determine what the firewire is blocking?

    I have all notifications turned on. Is there a firewall log that I can't find?

    I found the logs:
    Event Viewer, Applications and Services Logs, Microsoft, Windows, Windows Firewall With Advanced Security, Firewall
    But it doesn't show anything when the OTA fails.
    Last edited by SteveMann; 28 Mar 2021 at 23:15.
      My Computer

  2. Posts : 1,728
    Windows 10 Pro x64 22H2

    One easy way to figure out which executable is being blocked is to use process monitor:

    Download it and run as Administrator.

    Next step is to configure filtering in process monitor to show only dropped connections, here is a link to customized setting for this task:

    Download it to your desktop, then in process monitor click on File -> Import configuration and locate downloaded configuration.

    Next step is to clear accumulated data by pressing following button marked in green in process monitor:
    What in the firewall is blocking my app?-untitled.png

    Now go ahead and try to reproduce your problem with Arduino IDE.
    Within process monitor all dropped TCP connections and closed TCP connections will be marked with Cyan color as soon as there is dropped data.

    Not all of this cyan lines are drops, but it should give you some picture.
    If you want to be 100% sure, click on filter to enable showing received TCP data as follows, click on red marked button:
    What in the firewall is blocking my app?-untitled2.png

    Here when filter opens up uncheck options that says
    Operation is TCP receive

    What in the firewall is blocking my app?-untitled3.png

    Click OK and now you can investigate which of the cyan lines are dropped packets and which ones are normal TCP close.
    For example if you see cyan lines without matching TCP receive then you know these lines are representing firewall problem with outbound traffic (not inbound!)

    Your next step is to investigate if within firewall there are block rules that contribute to dropping packets.
    If not, next step see if default outbound is set to block in firewall, and if so create allow rule for dropped packets.
      My Computer

  3. Posts : 55
    Windows 10 Anniversary (Pro)
    Thread Starter


    Love your tagline. I hope that isn't me....

    I am used to seeing a firehose of information in a log file on Ubuntu, but ProcMon is the Niagra of data.
    I finally got the hang of the filter since scanning through 20 million events would take me until Windows 11 is released.

    I saw some Arduino-builder.exe events doing TCP activity, but no cyan lines. Not one.


    Issue SOLVED

    On the Arduino forums, someone noticed that turning off the public network was what allowed the OTA feature to work. He questioned why was my network type "Public"?

    Well, a few weeks ago I replaced my router and was having problems getting my Epson WiFi printer to connect to this PC. At some point in the diagnosis I probably changed the network type to "Public". Changing it back to "Private" solved the issue of OTA not functioning.

    BTW, thanks for the ProcMon tip. I identified an app that I never use that was generating thousands of events per second. I removed the program.
    Last edited by SteveMann; 29 Mar 2021 at 11:05.
      My Computer

  4. Posts : 1,728
    Windows 10 Pro x64 22H2

    Setting to private sound like easy solution, thanks for feedback

    Very likely Audrino IDE requires functionality on LAN, for which you need private profile.
      My Computer

  5. Posts : 55
    Windows 10 Anniversary (Pro)
    Thread Starter

    No, not the IDE. Which is why the problem was unnoticed for days or weeks. Being on a public network stops the OTA feature where I upload the code to the target device over WiFi.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:39.
Find Us

Windows 10 Forums