Help: rule exists but the program doesn't get through the firewall Solved

  1.    #1

    Help: rule exists but the program doesn't get through the firewall


    Hi there,

    I'm trying to allow a program (Cinema 4D) through the firewall but no matter what I do the access to the Internet for this particular program it's always blocked.

    I'm using Malwarebytes Windows Firewall Control (so far it worked fine with all the other software installed). With the right click on the .exe, I allowed the program through Windows Firewall but with no success.

    Assuming Malwarebytes for some reason isn't working (though in the end I know it's just a filter to Windows built-in firewall), I then closed Malwarebytes (by exiting the program) and tried directly in Windows Firewall.
    I first tried from the Windows Security Center by clicking on "Allow an app through firewall" and still nothing.
    Then I tried with Windows Defender by adding inbound and outbound rules giving the .exe access to all (domain, private, and public). No luck.

    At this point, I'm out of ideas.
    Hope there's still something left I can try. Any hints?
      My ComputerSystem Spec

  2.    #2

    Sorry if you have already tried this , but when you first open Cinema 4d, you can try and have a look in the "Connections Log" to check if it shows any other possibly associated files ( I am thinking of plugins but there may be others ? ) aside from cinema 4d that got blocked at that instant and then allow those files through as well. (Note that you may need to press F5 to see the updated log at any time). Other than that, I have no idea what other Service, Port or Rule might be blocking it.

    for ref: page 12; Malwarebytes-WFC-User-Guide.pdf

    http://www.google.co.uk/url?q=https:..._92ZrxxsDn7Gu2
    Last edited by das10; 09 May 2019 at 08:01.
      My ComputerSystem Spec

  3. Compumind's Avatar
    Posts : 973
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
       #3

    @verysame -

    Why would the program need to be "unblocked" in the first place?

    Remove all rules realted to Cinema 4D in WD and MBAM. No traces should remain.
    Then try cleanly uninstall (then reboot) and reinstall the Maxon Cinema 4D program.

    We can go from there.

      My ComputerSystem Spec

  4.    #4

    @das10 thanks! I had overlooked the Connections Log. After I opened it, I've found other several connections for Cinema 4D. I unblocked one of them and that did the trick! Thank you so much, it finally works!

    Thank you @Compumind for chiming in, with the Connections Log tool in MBAM I've been able to track down the service that was holding back the connection.
      My ComputerSystem Spec

  5.    #5

    Glad to know you overcame the issue; please mark the thead resolved.

    Thanks.
      My ComputerSystem Spec

  6. Compumind's Avatar
    Posts : 973
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
       #6

    Yes, glad you were able to track it down.
    I wonder what service was holding back the connection, though!

      My ComputerSystem Spec



 

Related Threads
Windows firewall ignores my rule that i set in AntiVirus, Firewalls and System Security
Iím running this program on my 2nd PC and when I installed it it automatically allows it through. But i then also set my own inbound and outbound rule to allow it. But windows firewall ignores this rule and continues not to allow it through. When...
Need help trying to add a firewall rule for an application... in AntiVirus, Firewalls and System Security
I have been trying to get this to work for almost a week now and I'm not having any luck. And as I've mentioned before, I'm not that great at vbscript. When I step through the vb.net part of the code, it looks like it should work, but it's not. I...
Smartscreen blocked by firewall - how to add rule to allow? in AntiVirus, Firewalls and System Security
Hello I have my firewall configured to block outbound connections that don't meet a rule. Although there are the default rules for Smartscreen still enabled, smartscreen still gives it's error message "Windows smartscreen can't be reached right...
Firewall rule to allow /24 in Network and Sharing
Is it possible to use this notation in a firewall rule? I am having issues with homegroup telling me the computer joined to the home group is currently unavailable even though they are set not to hibernate/sleep. If I disable the firewall(s) then...
Solved windows firewall upload rule in AntiVirus, Firewalls and System Security
anyone can help with windows firewall cant find option for limit upload? nvm
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:14.
Find Us