A new Win 7 to Win 10 upgrade - Broken Defender problem

Page 2 of 4 FirstFirst 1234 LastLast

  1. Posts : 24
    Windows 10
    Thread Starter
       #11

    zbook said:
    These are trial and error steps to fix the firewall:

    Open administrative command prompt and type or copy and paste:
    a) Netsh advfirewall set currentprofile state on
    b) netsh advfirewall set currentprofile firewallpolicy blockinboundalways,allowoutbound

    The result if it works should appear:
    Code:
    C:\WINDOWS\system32>Netsh advfirewall set currentprofile state on
    Ok.
    
    C:\WINDOWS\system32>netsh advfirewall set currentprofile firewallpolicy blockinboundalways,allowoutbound
    Ok.
    https://support.microsoft.com/en-us/...d-of-the-netsh

    View the Firewall and Network protection settings and post an image into the thread.
    I believe that the firewall was ALWAYS running, just the inbound rule issue as being reported.

    A new Win 7 to Win 10 upgrade - Broken Defender problem-capture.jpg

    Another thing that I want to note that does not appear correct is that the C:\Program Files\Windows Defender sub directory shows ALL of the files dated 9/15/2018. On a Win 10 Pro laptop, the file dates are all fairly recent within a couple of months of one another. Not sure what to make of this but it sure seems like something is not correct.

    Thanks again for your help and advise -
    Jim
      My Computer

  2. das10's Avatar
    Posts : 1,964
    Win 10 pro 1909
       #12

    rfdes said:
    "I want to note that does not appear correct is that the C:\Program Files\Windows Defender sub directory shows ALL of the files dated 9/15/2018"

    This would not be an issue here; I have the same dates and Windows Defender is running OK for me and I am running on the latest version of Win 10.

    ps: Did you try dalchina's recommendation to "Fix Windows Defender Does Not Start - Troubleshooter" ?
      My Computer


  3. Posts : 24
    Windows 10
    Thread Starter
       #13

    dalchina said:
    Fix Windows Defender Does Not Start - Troubleshooter
    - does any of this help?

    For example, you mention a service- there are 3..
    Yes, all three services are running. I followed everything in the troubleshooter with no luck. I should mention that the problem is not that the service(s) are running but that I cannot enable 'Real-Time Protection', perform a scan and cannot update definitions.
      My Computer


  4. Posts : 24
    Windows 10
    Thread Starter
       #14

    das10 said:
    rfdes said:
    "I want to note that does not appear correct is that the C:\Program Files\Windows Defender sub directory shows ALL of the files dated 9/15/2018"

    This would not be an issue here; I have the same dates and Windows Defender is running OK for me and I am running on the latest version of Win 10.
    That's interesting, I just performed my Win7 to Win10 a couple of days ago and would have thought that the Defender folder would agree somewhat with my Win 10 laptop. The file dates on my Laptop are all over the spectrum but the Desktop Win7 upgrade are all the same date. In fact the desktop defender folder doesn't have the file MSASCui.exe. MS is changing things so fast and furious you cannot make a side-by-side compare and make any sense of it.
    thanks
    Jim
      My Computer

  5. Bree's Avatar
    Posts : 15,408
    10 Home x64 (2004) (10 Pro on 2nd pc)
       #15

    rfdes said:
    ... In fact the desktop defender folder doesn't have the file MSASCui.exe. MS is changing things so fast and furious you cannot make a side-by-side compare and make any sense of it.
    The 'sense' is that the old green 'Microsoft Security Essentials' Win32 executable for the Defender UI has been replaced by the 'Windows Security' UWP app. MSASCui.exe was the MSE-style executable and MSASCuil.exe was the taskbar notification icon.

    The move started in 1703 when the 'Windows Defender Security Centre' app (as it was then named) first appeared. MSASCui was hidden but still worked if you knew where to look for it.

    .A new Win 7 to Win 10 upgrade - Broken Defender problem-scan-1703.png

    By 1803 it stopped working and was removed in 1809.
      My Computers


  6. Posts : 24
    Windows 10
    Thread Starter
       #16

    Bree said:
    The 'sense' is that the old green 'Microsoft Security Essentials' Win32 executable for the Defender UI has been replaced by the 'Windows Security' UWP app. MSASCui.exe was the MSE-style executable and MSASCuil.exe was the taskbar notification icon.

    The move started in 1703 when the 'Windows Defender Security Centre' app (as it was then named) first appeared. MSASCui was hidden but still worked if you knew where to look for it.

    .A new Win 7 to Win 10 upgrade - Broken Defender problem-scan-1703.png

    By 1803 it stopped working and was removed in 1809.
    Oh, OK... thanks for explaining that to me.
      My Computer


  7. NMI's Avatar
    NMI
    Posts : 471
    Windows 10 Pro, Version 1909
       #17

    Did you check the Malwarebytes Premium setting in post #10?
      My Computer


  8. Posts : 24
    Windows 10
    Thread Starter
       #18

    NMI said:
    Did you check the Malwarebytes Premium setting in post #10?
    I actually ended up using the Malwarebytes removal tool. They claim this removes everything. Has this been proven otherwise?
    Thanks for responding.
    Jim
      My Computer


  9. Posts : 24
    Windows 10
    Thread Starter
       #19

    Still no luck. Last night I cloned the drive and went back and reinstalled the update. This time with 'only save files' and the problem cleared itself. So now I have two drives, both Win 10 pro, 1 with all my settings/files & apps and 1 with only files. I have so many apps installed for my business I'm really wanting to resolve the issue as opposed to reinstalling all the apps.

    Does anyone have any other suggestions?
    Talking about frustrating! I was fretting doing this upgrade.

    Again, is there a log file that I can interrogate which would help isolate the issue?
    Jim
      My Computer

  10. dalchina's Avatar
    Posts : 24,253
    Win 10 Pro (1903)
       #20

    Still no luck. Last night I cloned the drive and went back and reinstalled the update. This time with 'only save files' and the problem cleared itself.
    Suggests you have something installed that is conflicting with Defender. But that might be just a remaining registry key, depending on how that process works, rather than a fully installed current program, perhaps relating to a security program you had installed at one point.

    If so, for example, a clean boot would not take you further forward, and finding it could be difficult.
    Last edited by dalchina; 19 Mar 2019 at 07:43.
      My Computers


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:49.
Find Us




Windows 10 Forums