Page 5 of 8 FirstFirst ... 34567 ... LastLast

  1. Joined : Oct 2013
    Posts : 16,584
    64-bit Windows 10 Pro build 14986
       2016-04-25 #40

      My System SpecsSystem Spec


  2. Joined : Jun 2016
    Posts : 1,383
    Win10 1607
       2016-07-02 #41

    Works For Raid to AHCI too ....


    This has worked ok for me on Win 10 , I left Raid on in the Bios after removing the Raid Array and installing Win10 , the difference is you only need to change the Start Overide Registry Entries to 0 ( from 3) as the other two are already 0 under Raid , on reboot after switching to AHCI in the Bios, the Controller was using the Microsoft AHCI Driver , after which I changed it to the Intel AHCI Driver. I did it manually as I already had the extracted Driver in a folder for my ICH10R Controller. I would assume you could run the normal WHQL Driver installer too.
      My System SpecsSystem Spec


  3. Joined : Oct 2013
    Posts : 16,584
    64-bit Windows 10 Pro build 14986
       2016-07-02 #42

    Thank you for confirming.
      My System SpecsSystem Spec


  4. Joined : Aug 2016
    Istanbul
    Posts : 5
    Windows 10 Home Edition 64bit
       2016-08-28 #43

    I've got only 2 questions to ask before trying this method and any help would be appreciated.

    First of all can i use my SDD with AHCI while i use my HDD with IDE? And second question is i have Storahci registery but i dont have İastorv, would that be a problem while procceding with the method?
      My System SpecsSystem Spec


  5. Joined : Oct 2013
    Posts : 16,584
    64-bit Windows 10 Pro build 14986
       2016-08-28 #44

    Hello Umut,

    I'm afraid that you cannot use AHCI while having an IDE HDD connected. Doing so would cause issues with the HDD.
      My System SpecsSystem Spec


  6. Joined : Aug 2016
    Istanbul
    Posts : 5
    Windows 10 Home Edition 64bit
       2016-08-28 #45

    Thank you for quick reply but i'm planing to buy another SSD to replace my HDD so my second question still stands.

    After i get a new SSD will i still be able to use this method with having Storahci registery but not having IastorV?
      My System SpecsSystem Spec


  7. Joined : Oct 2013
    Posts : 16,584
    64-bit Windows 10 Pro build 14986
       2016-08-28 #46

    You should have a iaStorAV key. Double check to make sure. If you don't then you can just add it.

    You will see a huge performance difference when you go from a IDE HDD to a AHCI SSD.
      My System SpecsSystem Spec


  8. Joined : Jun 2016
    Posts : 1,383
    Win10 1607
       2016-08-28 #47

    Why do you have the HDD in IDE mode ? is it not possible to switch it to AHCI ?

    the Caviar black will run in AHCI or RAID too , I use the 3 of 640GB version in a RAID 0 array

    KB
      My System SpecsSystem Spec


  9. Joined : Aug 2016
    Istanbul
    Posts : 5
    Windows 10 Home Edition 64bit
       2016-08-28 #48

    Its a 3 year old pc and i never searched about IDE & AHCI until today. Because my pc was working fine with Windows 7 until installing Windows 10 last month. After that, ONLY when i open 8-9 browser tabs sometimes SSD usage increases to %100 and a few second later everything freezes around a minute or so. After freeze everything goes to normal and SSD starts to act normal. So after searching everything i suspected something wrong my SSD and did a read/write test which ended with approximately 200ish mb(which is low)

    Anyway after searching a little bit more of what Brink said about AHCI causing issues about HDD i found something. If a HDD supports NCQ it's safe to use AHCI(in fact should use it). Now i changed my mobo to AHCI and i have no problem with SSD and HDD. Also my SSD read speed is 400ish mb now.

    Anyway if anything bad happens i will write it here so others may be aware before trying. Also i will continue to search my pc freeze because i dont think it is entirely related to ''IDE to AHCI enable''.
      My System SpecsSystem Spec


  10. Joined : Jun 2016
    Posts : 1,383
    Win10 1607
       2016-08-28 #49

    Umut said: View Post
    Its a 3 year old pc and i never searched about IDE & AHCI until today. Because my pc was working fine with Windows 7 until installing Windows 10 last month. After that, ONLY when i open 8-9 browser tabs sometimes SSD usage increases to %100 and a few second later everything freezes around a minute or so. After freeze everything goes to normal and SSD starts to act normal. So after searching everything i suspected something wrong my SSD and did a read/write test which ended with approximately 200ish mb(which is low)

    Anyway after searching a little bit more of what Brink said about AHCI causing issues about HDD i found something. If a HDD supports NCQ it's safe to use AHCI(in fact should use it). Now i changed my mobo to AHCI and i have no problem with SSD and HDD. Also my SSD read speed is 400ish mb now.

    Anyway if anything bad happens i will write it here so others may be aware before trying. Also i will continue to search my pc freeze because i dont think it is entirely related to ''IDE to AHCI enable''.

    Check your SSD has the latest Firmware for it too...... some Sandforce Controllers had problems a few years ago....

    maybe this one?
    Force Series™ GS 128GB SATA 3 6Gb/s Solid-State Hard Drive
      My System SpecsSystem Spec


 
Page 5 of 8 FirstFirst ... 34567 ... LastLast


Similar Threads
Tutorial Category
Windows Update Automatic Updates - Enable or Disable in Windows 10
How to Enable or Disable Automatic Updates for Windows Update in Windows 10 Windows 10 will automatically check for new Windows Updates at the time you have set in automatic maintenance. Windows 10 will automatically download and install...
Tutorials
Solved Attn. SSD owners - Enabling AHCI mode AFTER Windows 10 installation.
Hello everybody. What started out as a request for guidance ended up with me solving my own problem. Thought I may as well pass on my findings anyway just in case it helps somebody else in the same situation. So over the weekend, through a series...
Drivers and Hardware
Is Windows 10 Standard AHCI Driver Sufficient?
I have an I5 Ivy-Bridge (B75 chipset) system. Windows 10 is up and running (fresh install) and I've been able to load all but the correct SATA drivers - still using the "Standard" AHCI SATA driver that windows installed. Asus hasn't released a...
Drivers and Hardware
Install AHCI Driver after Win 10 installation
Hi All. I would appreciate some help on this one. I found a spare 160GB SATA Drive on which I have decided to install a trial of Win 10 to explore it further for now. The only way that I could get this HD to be seen in the BIOS would be to...
Drivers and Hardware
AHCI still not fixed???
has anyone found any information about ms fixing ahci in win 10? i just can't believe after so many months that they STILL have not fixed this. any new information is appreciated. thanks!
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:54.
Find Us
Twitter Facebook Google+



Windows 10 Forums