1.    05 Apr 2016 #1
    Join Date : Apr 2016
    Posts : 3
    Windows 10 Home

    Windows 10 is a tad slow...

    I think this is a bit of a vague issue to troubleshoot what bothers me is that installers are taking a long while to install and move/copy operations appear to be unusually long with files that are 1Kb in size and apart from basic defragmentation and use of Windows and uninstalling unnecessary programs, I am not sure how to clean the hive without having to uninstall, also considering that the laptop was shipped without the CD, somehow.

    The idea of using software to fine-tune software might give me a false sense of security sometimes, what do you think?

    Further reading
    1. Registry Hives (Windows)
    2. Uniblue pc performance utilities for Windows - Uniblue - System Utilities to Improve PC Performance and Stability
    3. Regcleaner - RegCleaner - Download
      My System SpecsSystem Spec

  2.    05 Apr 2016 #2
    Join Date : Mar 2015
    Posts : 1,020
    Windows 10 Pro x64

    Since you mentioned a defragger, I am guessing you are using a spinner HDD? I've loaded Windows 10 on about 40 machines so far, most of which have SSDs. There is definitely a difference that's more pronounced in Windows 10 when comparing a system with an HDD to an SSD.
      My System SpecsSystem Spec

  3.    06 Apr 2016 #3
    Join Date : Oct 2015
    Posts : 11
    Windows 10 Professional

    Yeah, even on a ssd i find small size file operations a bit slow, perhaps, try excluding explorer.exe from windows defender and see if you get better performance? Other thing to try is to use command prompt robocopy to perform those operations?
      My System SpecsSystem Spec

  4.    08 Apr 2016 #4
    Join Date : Jan 2016
    Canada Quebec
    Posts : 21
    Windows 10 pro 64bit

    do you have an SSD?
      My System SpecsSystem Spec


Similar Threads
Thread Forum
Solved Windows 10 seems slow
Is it me or does windows 10 seem slow to anyone else. its not like i got a ancient laptop its a lenovo t430s got a i7 3520m 2.90ghz with 16 gigs of ram but boy it loads slow and seems to run slow.
Performance & Maintenance
Solved Slow boot time on SSD and slow Desktop icons loading
Hi all, I'm using an Intel SSD 240GB 520 series. Always loading very fast, i.e., about 8 seconds from cold boot. Since windows 10 is installed, boot time is about 20 seconds and desktop icons take some time to refresh and load their images. ...
Performance & Maintenance
Solved Windows 10 Download - Very Slow!
I've used the Microsoft Media Creation Tool x64 to effect a Win 10 download. The download is painfully slow. What's up with that?
Installation and Setup
Windows becomes slow
Hello guys, I have some problems with this operating system. Everything works well but after a while it gets slow. Here's how it goes: If I turn on my laptop and let the Windows load 100% everything works smooth without any problems. Explorer...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:15.
Find Us
Twitter Facebook Google+

Windows 10 Forums