1. Join Date : Nov 2016
    Posts : 8
    Windows 10
       3 Weeks Ago #1

    Problem: "Ethernet doesn't have a valid IP configuration" Lenovo


    Dear Tenforums users,

    I have recently encountered some problems wth my relatively new Lenovo IdeaPad laptop;
    whenever I try to connect to the internet using ethernet it tells me that
    "Ethernet doesn't have a valid IP configuration"

    I have the Realtek PCIe GBE family controller as my ethernet device.

    I have browsed the internet about it and tried to update the ethernet driver via device manager. However, even after doing that, nothing has changed. I am currently using Wifi, but at my work location the connection via WLAN is very... bad.

    I hardly have any knowledge about drivers and BIOS and stuff. I hope that anyone amongst you is able and willing to help me out in this matter!

    I sincerely thank you all for your time!

    Yours,

    esmorax
      My System SpecsSystem Spec


  2. Join Date : Jul 2016
    Crewe Cheshire
    Posts : 367
    windows 10
       3 Weeks Ago #2

    open a cmd prompt then type ipconfig /all post results
      My System SpecsSystem Spec


  3. Join Date : Nov 2016
    Posts : 8
    Windows 10
       3 Weeks Ago #3

    Dear Samuria,

    As requested the ipconfig/all results:

    Windows IP Configuration Host Name . . . . . . . . . . . . : Kevin-Lenovo Primary Dns Suffix . . . . . . . : Node Type . . . . . . . . . . . . : Hybrid IP Routing Enabled. . . . . . . . : No WINS Proxy Enabled. . . . . . . . : No DNS Suffix Search List. . . . . . : HomeEthernet adapter Ethernet: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller Physical Address. . . . . . . . . : 54-EE-75-7D-B1-C2 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesWireless LAN adapter Local Area Connection* 2: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter Physical Address. . . . . . . . . : E0-94-67-40-30-EA DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesWireless LAN adapter Wi-Fi: Connection-specific DNS Suffix . : Home Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 3165 Physical Address. . . . . . . . . : E0-94-67-40-30-E9 DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : Yes Link-local IPv6 Address . . . . . : fe80::f8fc:7f2e:3127:b684%5(Preferred) IPv4 Address. . . . . . . . . . . : 192.168.1.20(Preferred) Subnet Mask . . . . . . . . . . . : 255.255.255.0 Lease Obtained. . . . . . . . . . : dinsdag 8 november 2016 23:09:47 Lease Expires . . . . . . . . . . : woensdag 9 november 2016 23:36:18 Default Gateway . . . . . . . . . : 192.168.1.1 DHCP Server . . . . . . . . . . . : 192.168.1.1 DHCPv6 IAID . . . . . . . . . . . : 65049703 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-E0-1A-61-54-EE-75-7D-B1-C2 DNS Servers . . . . . . . . . . . : 192.168.1.1 NetBIOS over Tcpip. . . . . . . . : EnabledEthernet adapter Bluetooth Network Connection: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Bluetooth PAN HelpText Physical Address. . . . . . . . . : E0-94-67-40-30-ED DHCP Enabled. . . . . . . . . . . : Yes Autoconfiguration Enabled . . . . : YesTunnel adapter Teredo Tunneling Pseudo-Interface: Connection-specific DNS Suffix . : Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6abd:386b:30f2:3f57:feeb(Preferred) Link-local IPv6 Address . . . . . : fe80::386b:30f2:3f57:feeb%14(Preferred) Default Gateway . . . . . . . . . : :: DHCPv6 IAID . . . . . . . . . . . : 402653184 DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-E0-1A-61-54-EE-75-7D-B1-C2 NetBIOS over Tcpip. . . . . . . . : DisabledTunnel adapter isatap.Home: Media State . . . . . . . . . . . : Media disconnected Connection-specific DNS Suffix . : Home Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3 Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0 DHCP Enabled. . . . . . . . . . . : No Autoconfiguration Enabled . . . . : Yes
      My System SpecsSystem Spec


  4. Join Date : Nov 2016
    Posts : 1
    Windows 10
       3 Weeks Ago #4

    Been having the same issue after applying an update today. Been going crazy for two hours now trying to resolve. In for a fix!
      My System SpecsSystem Spec


  5. Join Date : Jul 2016
    Crewe Cheshire
    Posts : 367
    windows 10
       3 Weeks Ago #5

    When you did that was there a network cable plugged in as it show its disconnected so if it was plugged in does it show a light on the router to show the cable is ok?
      My System SpecsSystem Spec


  6. Join Date : Nov 2016
    Posts : 8
    Windows 10
       3 Weeks Ago #6

    Samuria said: View Post
    When you did that was there a network cable plugged in as it show its disconnected so if it was plugged in does it show a light on the router to show the cable is ok?
    I rebooted my PC after first deinstalling the Ethernet driver (for the 2nd time) and doing a clean install of the driver downloaded from Lenovo site. I also rebooted the router at that time. WHen I plugged in the cable it was FINALLY recognized and I managed to get a connection!

    I hope it will stay working now! Will post if I encounter new issues! Thanks for your comments and help!

    -esmorax
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved Ethernet doesn't have a valid IP configuration
So... I just updated from win 7 to win 10, as I got it for free. All went smoothly, but there was no ethernet connection. I'm running a custom built pc, connected to my router via ethernet cable. At first windows detected the cable, but said:...
Network and Sharing
"ethernet" doesnt have a valid IP configuration
I have looked at almost every post on the forum and have tried different steps to correct my issue with no luck. I have a wired connection to my modem and its green light on both ends of the connection. In Network and Sharing it says Unidentified...
Network and Sharing
Solved Default gateway unavailable and "Ethernet" Doesn't have a valid ip con
So I have been able to use my pc fine until the internet loses connection, so I troubleshoot and It says: The default gateway is not available, I had this error a few days ago and managed to fix it by setting my ip to obtain automatically, I tried...
Network and Sharing
Solved Ethernet doesn't have a valid IP configuration
Hello, I'm about 4 hours deep into trying to fix this. I've followed several forum posts with similar issues, with no luck. I've been running windows 10 on my PC with my current hardware (including modem/router) for about a year now with no...
Network and Sharing
"Ethernet" doesn't have a valid IP Configuration
Hello. I have been trying to fix this for the last 4-5 hours with no luck. I swear the computer was working fine just a few days ago. This evening, there's a yellow warning triangle above my internet icon. Setup: Centurylink DSL connected...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:15.
Find Us
Twitter Facebook Google+



Windows 10 Forums