Hoping someone can help me with this...scanning to external hard drive attached to router.

My setup:

Windows 10 on a Dell Optiplex 9010 (purchased from Dell's refurbished site, if that means anything)
Asus RT-AC3200 router
HP OfficeJet Pro 8720 printer
Printer is connected via ethernet from switch (cannot be attached by USB cable as location is on opposite side of house)

I can scan to desktop, email, print wireless from laptop, any iPhone/iPad.

I've mapped the network hard drive. I originally noticed I had some permission issues, which I still think may be the case, and even though my user account is listed as Administrator, the only way I could change any kind of permissions anywhere seemed to come by way going to CMD and entering

Net user administrator /active:yes

then changing permissions from this account.

One thing I noticed last night was that when I looked at permissions on the mapped hard drive was that it still says "Special Permissions" only. I change it, hit Apply, and the check marks disappear, changing nothing. I'm not sure which account I was signed into at that moment.

On router, I've enabled share with read/write permissions on all folders within the external hard drive, enabled sharing on media server, FTP share...I'm trying anything and everything with my limited IT knowledge.

I'm at a loss as Asus techs weren't successful in helping resolve issue and a friend in IT logged in remotely to check to it out to no avail, but the friend only could spare about 10 minutes.

Anyone have some thoughts or suggestions please?