1.    24 Aug 2015 #1
    Join Date : Aug 2015
    Posts : 2
    Windows 10

    [solved] Ethernet doesn't have a valid IP configuration

    So... I just updated from win 7 to win 10, as I got it for free. All went smoothly, but there was no ethernet connection. I'm running a custom built pc, connected to my router via ethernet cable.

    At first windows detected the cable, but said: ''Ethernet doesn't have a valid IP configuration." I was on about around the settings, and deleted the ethernet network from windows' settings. I thought it would come back by just re-plugging the cable. This didn't happen. What happened was, that the whole 'Ethernet' tab disappeared from the 'Network & internet' menu!

    I also don't have 'Wi-fi' or 'Airplane mode' tabs in the menu... Well I have a pc that doesn't have support for wifi so that might be why...

    Does anyone have a clue on how to get win 10 to detect the ethernet cable, and maybe that way bring back the 'ethernet' tab?

    Oh, and I tested the ethernet cable on my laptop (running win 7), and it worked fine.

    Thanks in advance!
    Last edited by raakku; 25 Aug 2015 at 01:31.
      My System SpecsSystem Spec

  2.    24 Aug 2015 #2
    Join Date : Aug 2015
    Posts : 2
    Win 10

    have you tried disabling and enabling the ethernet from device manager?
      My System SpecsSystem Spec

  3.    24 Aug 2015 #3
    Join Date : Aug 2015
    Posts : 126
    windows 10

    in run box type ncpa.cpl
    and let us know if you see Network connection icons if no, reinstall ethernet drivers if yes what does it say, (unidentified, No access etc)
    Are you directly connected to Modem or is there a router is between.
      My System SpecsSystem Spec

  4.    25 Aug 2015 #4
    Join Date : Aug 2015
    Posts : 2
    Windows 10

    Well, I got it fixed... Should have thought of updating the drivers earlier, I guess it was kinda obvious. It's pretty hard though, to download drivers from the internet, without an internet connection... Plugged my phone to the computer via usb, and shared the phones internet connection.

    If someone else has the Ethernet tab missing, I got it back by going to Control panel - Network and sharing center - 'change adapter settings' there I re-enabled the ethernet connection I had deleted earlier.
      My System SpecsSystem Spec

  5.    11 Nov 2015 #5
    Join Date : Nov 2015
    Posts : 1
    Windows 10

    I had the same problem. I upgraded from a perfectly working Asus M32 running Windows 8.1 to Windows 10. After the install I had no internet connection and the troubleshooter told me "ethernet doesn't have a valid IP configuration". I uninstalled my Intel Ethernet driver by going to the control panel>device manager>network adapters>Intel Ethernet Connection 1217-V>right click>uninstall>OK. I used my other computer to download the driver and reinstalled it. BOOM! Internet connected. I don't know if the problem is with Intel ethernet drivers or others. Regardless of the brand... reinstall the ethernet driver. (:-)V(:-) Intel Download Center
      My System SpecsSystem Spec

  6.    11 Nov 2015 #6
    Join Date : Sep 2015
    Posts : 2,191
    Windows 10 Pro 64-bit 1607 (AE build 14393.321)

    That's why I recommend to download any drivers beforehand when upgrading to a new OS. I have had this problem myself in the past, so I now know and advise others to download any drivers beforehand.
      My System SpecsSystem Spec

  7.    12 Nov 2015 #7
    Join Date : Mar 2015
    Posts : 1,022
    Windows 10 Pro x64

    Quote Originally Posted by spapakons View Post
    That's why I recommend to download any drivers beforehand when upgrading to a new OS. I have had this problem myself in the past, so I now know and advise others to download any drivers beforehand.
    Always a great idea. I keep a flash drive updated with drivers and important apps. This way, if I ever need to reinstall or set up a new machine, what I need is readily available.
      My System SpecsSystem Spec

  8.    30 Aug 2016 #8
    Join Date : Jul 2015
    Posts : 133
    Windows 10

    This worked today on my Windows 10 Anniversary

      My System SpecsSystem Spec


Similar Threads
Thread Forum
Boot configuration lost for win10
Woke up my PC from sleep mode today and found out there was an update applied played most of the day today and when I got one of my notorious video feed loss computer freeze I restarted Mt machine and now I have a boot configuration data failure...
General Support
Valid Win7 Product Key not accepted by Win 10 upgrade
Having upgraded my laptop and Surface Pro to Win 10, my neighbour asked me to do the same for his laptop running its original OEM applied Win7.1 Home premium. Unlike my 2 machines, when the win10 upgrade gets to the Product Key entry screen,...
Installation and Setup
Windows Insider key no longer valid?
Hello Woke up this am and says my computer was not activated. Logged out and logged in. Yes logged in to my Microsoft account. says i am not connected to internet. clearly I am because i can surf websites. Few hours later i tried to activate...
Windows Insider
Old Technet ISOs - Keys becoming not valid ?????
Hi there I tried re-installing Windows 8.1 Enterprise that I downloaded from TechNet during my subscription --it's the VL multiple activation one. The Keys don't activate it any more -- I've only activated it about 3 times and it IS a VL one...
Windows Updates and Activation
Solved I can't install W10. It says my disk is not valid.
Hi, I never saw something like this. It says that there is someproblem with my disk, in all of the partitions. I can't remember the exact message, but it was something with an acronym such as GTMP problem. This laptop is one year old, runs...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:05.
Find Us
Twitter Facebook Google+

Windows 10 Forums