Thought I would report on a very good experience. My comp has been upgraded through various OSs and has been on the insider program since Oct, and was on 10240. While it was running fine, there were indicators that it would benefit from a 'clean' install.

So, after a fair bit of agonizing, I decided to go for a reinstall. I took an image and also copied my files and appdata and a few other things like favorites and Documents! I had a few qualms about whether the few paid for progs would install OK and also about Picasa and its databases.

I did a test install from my rufused 1024 USB drive onto a new spare HDD and all went well so next was my SSD!

ISO booted up fine and I chose NOT to install my progs. In 13 min it was done. That was quick! Started it up and found all my data folders were still there, except for Documents. My windows.old was 53GB!

In a nutshell, the re-install of my progs went well but I have to say my Picasa re-install went way beyond my expectations. My main image folder (C:\Images) was already in place, as before, so I installed Picasa and fired it up. EVERYTHING was as it was before! The databases had by some miracle been restored to the right place and it just worked. Wow, I was impressed.

Activation etc - it did ask for a key so I gave it VK7JG-NPHTM-C97JM-9MPGT-3V66T. Seemed happy with that. Showed 10 PRO and activated in Activation settings. I had to rejoin the Insider program and that went fine. Changed default Slow to Fast update stream. You will get a new Computer Name so you will probably want to change that back to what it was.

After a few hours of re-installing the essentials (bought progs went back OK) I now have a much leaner and cleaner machine and am very pleased I bit the bullet.

A tip about setting up your user ID. DON'T add your MS account at install time. Skip this and you then get to add a user name of your choice.

A good move for me (my comp!) and an additional positive learning experience.

Well done MS. Only five days to go!!