1.    24 Jun 2016 #1
    Join Date : Jun 2016
    Posts : 2
    Windows 8 Pro

    Windows 10 install problem 0xC1900101 - 0x20017


    I have a problem with installing Windows 10 (either upgrade or clean install). I think the problem has started 2.5 years ago when suddenly Windows 8 stopped installing updates. I think it stopped installing updates after the Windows 8.1 upgrade through the store has failed.

    Just about a month ago, updates resumed and a bunch of them were installed. But after several days, one security update has failed to install and Windows update is stuck at this point.

    I decided last week to upgrade to Windows 10. Direct upgrade wasn't possible because I have o upgrade to Windows 8.1 first, which I can't. So I have created a clean install media on USB using the media creation tool. I plugged in the USB, shut down then started and selected the USB drive as first choice for booting. It brought the Windows logo, and 1 minute later, the laptop shut down. I repeated the operation twice with the same result.

    I tried then to do a clean install of Windows 8.1 from another USB, but shortly after the logo, instead of shutting down, I got a light blue screen with "something went wrong" message and the machine restarted.

    Then I decided to run the USB that have Windows 10 from Windows. I selected to remove every thing and proceeded. The process after that went slow increment of 1% took about 10 minutes. Then I got the first restart, and it went the same as it shut down. I started the laptop and it went again to Windows 8. After I logged on, I got the following message:

    We couldn't install Windows 10
    We've set your PC back to the way it was right before you started installing Windows 10.

    0xC1900101 - 0x20017
    The installation failed in the SAFE_OS phase with an error during boot operation.

    I have found some solutions on the internet, but I am not sure if they will work, considering the history of my machine.

      My System SpecsSystem Spec

  2.    25 Jun 2016 #2
    Join Date : Apr 2015
    Posts : 8,779

    Hi onyr and welcome to Tenforums.

    I think, when you do the clean install of W10, you need to make sure you have removed all partitions and are installing to a drive which shows as "unallocated". See in the tutorial:
    Windows 10 - Clean Install - Windows 10 Forums

    Specifically you want to be sure your drive looks like this before you begin:

    Click image for larger version. 

Name:	unallocated-drive-space.PNG 
Views:	11 
Size:	77.4 KB 
ID:	86780

    Unless your drive is failing, this should do it.

    Before you start, perhaps you might want to run chkdsk on your OS drive.

    At an administrative command prompt, enter
    chkdsk c: /r
    enter, and reboot the machine. Chkdsk will run at boot.

    EDIT: p.s Please make sure Fast Startup is turned off to get a proper boot.
    Last edited by simrick; 25 Jun 2016 at 13:34. Reason: Fast Startup
      My System SpecsSystem Spec

  3.    26 Jun 2016 #3
    Join Date : Jun 2016
    Posts : 2
    Windows 8 Pro

    Hi simrick ,

    Thank you for the info and the welcome. I will try your suggestion.
      My System SpecsSystem Spec

  4.    26 Jun 2016 #4
    Join Date : Apr 2015
    Posts : 8,779

    Quote Originally Posted by onyr View Post
    Hi simrick ,

    Thank you for the info and the welcome. I will try your suggestion.
    Good luck and let us know how it goes.
      My System SpecsSystem Spec


Similar Threads
Thread Forum
0xC1900101 - 0x20017 happens every time I install.
Hey all. I reserved my copy of W10 a long time ago, and I just got back from vacation, so I thought I would just go ahead and install using the Media Creation tool. After running the tool and downloading it, it installed fine and proceeded to...
Windows Updates and Activation
Error 0xC1900101 - 0x20017 when upgrading Win 7 pro on a Lenovo E540
Hello, I've a laptop Lenovo E540 which is currently setup with dual boot Windows 7 professional and Debian Linux. I'm using there only Linux, I've just activated Windows when I bought the machine last year and never used it again. I decided to...
Installation and Setup
0xC1900101-0x20017 Error during BOOT
35046Windows 10 goes through the entire download/installation process, restarts, blue screens with a "system thread exception not handled (iastora.sys). It then restarts and shows this error for windows 10. Am I screwed? It goes back to the desktop...
General Support
Win10 home will not install - 0xc1900101 - 0x20017
Please help me solve this problem which is driving me nuts. Yes, I have searched for solutions and have not yet found a reasonable one. I have Win 10 installed and activated on one computer - Asus z97 Deluxe/USB 3.1 mobo - but it ABSOLUTELY refuses...
Installation and Setup
Win 10 Error code 0xc1900101-0x20017 SAFE_OS During Boot
I'm using the MediaCreationToolx64 and received the error message shown in the title as the actual installation started. That is, after all the checking for updates etc. The system was returned to its original Win 8.1 state. Does the error code or...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:31.
Find Us
Twitter Facebook Google+

Windows 10 Forums