Page 2 of 2 FirstFirst 12
  1.    25 Apr 2016 #11
    Join Date : Jun 2015
    Posts : 197
    Win10 Pro x64

    Ok so while I was poking around in my BIOS I noticed that I actually had the SSD plugged into the discrete sata port on accident. I switched it over to one of the normal 6,and now the SSD IS seen as a removable device:

    I don't think I can set the ports manually, and isn't matrix the older version of Intel RST, and aren't both of those for RAID setups?
      My System SpecsSystem Spec

  2.    25 Apr 2016 #12
    Join Date : Jun 2015
    Posts : 197
    Win10 Pro x64

    I had to install a really old version of RST since my platform is unsupported by the latest revision. It is no longer showing up in the notification area (although I still have microsoft storage spaces controller under device manager). Marking this as solved since the original problem is resolved
      My System SpecsSystem Spec

  3.    25 Apr 2016 #13
    Join Date : Jul 2015
    PA, USA
    Posts : 460
    Windows 10 Pro (Mix of Builds) / Linux Mint

    Good to hear you got it!
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12

Similar Threads
Thread Forum
SSD shown in Safetly Remove Hardware and Eject Media
I have a problem with two of my SSD's showing up as removable and non internal. One has my operating system on it so I'm hesitant to remove that one, but the other one only has games on it so I can use that for testing purposes. Here's some of what...
Drivers and Hardware
Explorer scanning for "Safely Remove Hardware and Eject Media"
When I boot up my system it will normally scan once and that's it. A couple weeks ago I started getting a system sound when I logged into a game I play Black Desert Online and the sound would repeat itself exactly every 2 minutes. I tried a reboot...
General Support
Solved Safely Remove Hardware and Eject video card???
Okay, a puzzler... My taskbar shows that I can "Safely Remove Hardware and Eject Media". Funny...I don't have anything plugged in. Selecting the message tells me that I can "Eject Nvidia GTX 970". Wouldn't that be odd? It's the friggin' video...
Graphic Cards
"Safely Remove Hardware and Eject Media" Always Appearing
Title says it all. Even without any flash drives connected to my PC, it still displays this. Didn't happen when I was back in Windows 7.
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:36.
Find Us
Twitter Facebook Google+

Windows 10 Forums