1.    05 Mar 2016 #1
    Join Date : Aug 2015
    Posts : 63
    Windows 10

    Windows 10 Hangs on Setup

    Hey everyone,
    Every time I try to reinstall Windows 10 it always hangs when I have to input my time zone, no keyboard inputs or mouse registration however keyboard and mouse works on BIOS, this is the screen that I get stuck at:

    Any help is appreciated, I'm starting to give up.
      My System SpecsSystem Spec

  2.    06 Mar 2016 #2

    If you can get into bios you may just have to enable usb keyboard legacy support in there , it may be turned off
      My System SpecsSystem Spec


Similar Threads
Thread Forum
Windows 10 setup: hangs on Checking for Updates
I am currently using windows 7 64-bit. I downloaded windows 10 from the ms site (the automatic icon never appeared on my pc), and am using the media creation tool. All goes fine until 'Getting Updates', when it hangs on 'checking for updates'....
Installation and Setup
Windows setup errors : Stuck at "Setup is starting"
Hi I got a problem now. My laptop cant install Windows. This is the story : Im playing games with my laptop for few hours and then my laptop got a crash and then im doing force shutdown. And then im realize that im accidently cause some...
Installation and Setup
Solved Windows 10 Setup hangs on the "Getting Updates" part.
Welp, i'm upgrading to Windows 10! But it hangs on this part... Do you guys got any ideas on how to speed this part up?43291 And yes, I am a huge Undertale fan! :D
Installation and Setup
Windows 10 hangs
Hi We have a windows 7 home premium , with Samsung RF10 laptop . Every time we try to upgrade to windows 10 it gets so far then hangs . We get as far as a dark blue screen with a pale blue windows icon , left it for to see if anything would...
Installation and Setup
Windows 10 Setup freeze/hangs at logo, loading circle not appearing
I just want to create my own Win10 here, but when I setup the VMs, and running it, It wasn't go well, It froze! I have tried add the size to 21GB, using UEFI, and deleting the EFI folder, but still not working Any clue? Here are my VM Specs : ...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:34.
Find Us
Twitter Facebook Google+

Windows 10 Forums