1.    22 Jun 2015 #1
    Join Date : Jun 2015
    Posts : 2
    Windows 10 Technical Preview

    Windows 10 Crashing on CLASSPNP.SYS in safemode and startup repair.

    I've just upgraded Windows 7 64-bit HP OEM to Windows 10 Technical preview 64-bit. Extracted the install while booted within 7, install went smoothly, opted to keep all my files, and once the install was finished it went to boot Windows 10. It hung on "Starting Windows", so I restarted and went to "Startup Repair". After loading the files it just stayed as a black screen and no longer loaded. Went to boot in Safemode, and it gets stuck on loading \Windows\system32\drivers\CLASSPNP.SYS.

    EDIT: I've now attempted to do a complete reinstall, and created a bootable USB drive, and it would also fail to boot that. Tried booting from DVD, also crashes during the boot to that. Even attempted reverting back to windows 7 and put in my old install disk to do that, also crashed. I can now no longer boot to anything windows related since installing windows 10. I can boot a live ubuntu CD, as well as Ultimate Boot CD (freeDOS), so I ran a memtest, CPU load test, HDD SMART test, and just about every other test on my hardware I can think of using my Ultimate Boot CD and my hardware is apparently fine with no faults. I just can't boot anything related to windows. Completely stuck, really need help.
    Last edited by Vianim; 22 Jun 2015 at 18:51.
      My System SpecsSystem Spec

  2.    29 Jun 2015 #2
    Join Date : Jun 2015
    Posts : 1
    windows 7pro 64-bit

    I've had the same issue. I recently purchased a new SSD hard drive for my home PC and wanted to put win10 on it.

    first thing I did was create a bootable DVD with the ISO for win10 ver. 10130.
    Next, I install windows 7pro 64-bit on the bland SSD and got it fully updated with all critical and optional updates along with all system drivers.
    Then started the windows 10 upgrade process which seemed to work fine.
    after finishing win10 install, the system would reboot itself and stop on the screen saying "Starting Windows" before the blue window logo appears.
    system will not get past that point. I started in safemode and the boot process seems to get hung up on classpnp.sys
    I made sure there was nothing plugged in to the PC except keyboard, mouse, monitor, ethernet and power.
    made sure BIOS is updated
    when trying to do a windows repair, I get a status bar saying "Loading files" when the status bar completes, the screen goes blank and the system locks up
    formatted the hard drive and installed win10 directly from the DVD and the same thing happens.

    I've been playing around with windows 10 without issue on an old Dell Optiplex at work for several months now.
    Any help or suggestions on how to get past this issue with classpnp.sys would be greatly appreciated.
      My System SpecsSystem Spec

  3.    29 Jun 2015 #3
    Join Date : Oct 2014
    Posts : 1,228
    win 10 Insider

    You guys are going to be lucky if someone here can tell you exactly what is wrong with your setups.

    Google this fault and try some of the suggestions/fixes. It looks like a problem related to the HDD.

    Good luck.
      My System SpecsSystem Spec

  4.    09 Jul 2015 #4
    Join Date : Jun 2015
    Posts : 2
    Windows 10 Technical Preview

    Quote Originally Posted by linw View Post
    You guys are going to be lucky if someone here can tell you exactly what is wrong with your setups.

    Google this fault and try some of the suggestions/fixes. It looks like a problem related to the HDD.

    Good luck.
    Youre right, I should have added my setup too see any possible links. Turns out what i had to do to "fix" this was to unplug everything in sata, do a complete wipe and reformat of the boot SSD, change the port of the boot drive, and only then i could do a clean install windows 7 back on my machine to get it working again. Very strangely it still hangs when i plug my data drives back in so i had to reformat them aswell :/. That upgrade to 10 did something strange to affect all my drives and prevented any windows OS from booting until i did a complete wipe. I just wish i knew how to diagnose this.
      My System SpecsSystem Spec


Similar Threads
Thread Forum
DISM - Repair Windows 10 Image
How to Repair Windows 10 Image using DISM If a Windows image becomes unserviceable, you can use the Deployment Imaging and Servicing Management (DISM) tool to update the files and correct the problem. For example, you would use DISM to fix...
Windows 10 clean install caused Repair Loop Error
Hi everyone, Win 7 user here, wanting to dual boot with Windows 10 preview (on a different partition). So I made a Win 10 usb boot disc, and it installed it fine. Played around with the new Windows for a few mins, whilst it downloaded an...
Installation and Setup
Windows 10 gets attacked with a disk repair in a multi-boot setup.
Before installing Win 10 preview onto an HDD I disconnect the other bootable drives lest they be molested by the Windows 10 install process. After installing the preview and updating everything I shutdown the PC and re-attach the other HDDs. My...
General Support
Windows 10 TP Repair and Recovery Features
I'm currently running the 10 TP in a virtual machine. I see that the various boot and repair options can be accessed by <shift> Restart from the desktop, however F8 during boot doesn't appear to work. Can someone who is actually running this on...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:56.
Find Us
Twitter Facebook Google+

Windows 10 Forums