1.    3 Weeks Ago #1

    dcom error 10016 re APPID F72671A9-012C-4725-9D2F-2A4D32D65169


    I wanted to start a new thread here although there are many others, the solutions don't work as they depend on changing permissions wherein this case the system won't permit this.

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {8D8F4F83-3594-4F07-8369-FC3C3CAE4919} and APPID {F72671A9-012C-4725-9D2F-2A4D32D65169} to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    All the suggestions I have seen recommend changing the owner to "administrators" and then amending the permissions, or in some cases removing the item altogether. However in this case (and others I have read) we are unable to amend, as the change is rejected.

    When I search the registry, hlm\software\classes\appid\F72671A9-012C-4725-9D2F-2A4D32D65169, the owner is listed as"all application packages" with only read permission. If I change the owner to administrators, I am given the option of ticking full control, but when I do so and tick "apply", I get "unable to save permissions changes on F72671A9-012C-4725-9D2F-2A4D32D65169 access denied". The same occurs if I attempt to delete the key.

    Lastly I am unable to find any Appid such as "runTimeBroker" with the key of F72671A9-012C-4725-9D2F-2A4D32D65169.

    As an aside I am trying to fix all Event errors as we have had so many probs (including over 900 event errors) since we upgraded from win7 to 10 - this hopefully is the last unresolved item, but time will tell!
      My System SpecsSystem Spec


  2. Joined : Oct 2015
    Posts : 1,205
    Windows 10 Pro X64
       3 Weeks Ago #2

    Hi,

    First of all make sure you are part of the administrators group.

    Run regedit and let it search for the first Hive Key.
    Right click it and select "Permissions" A box will pop up. Tick "Advanced"
    Another box appears and you will see that the Hive Key is owned by "Trusted Installer"

    Click on "Change" and type "Administrators" (without the quotation marks). Click apply and OK until your back into the first panel. Select Administrators from the list there and click on the "Full Control" check box.

    Now do the same for the next Hive Key.

    Leave Regedit open and run dcomcnfg. Click on the right hand side object until you see dcomconfig. Double click it and scroll down to the object named:

    {F72671A9-012C-4725-9D2F-2A4D32D65169}

    Right click that and select "Properties". Under "Launch and Activation" click on "Edit" . Add User "SYSTEM" (no quotes),
    Click OK. Back in the first panel select "SYSTEM" and click on the local permissions.

    Close dcomcnfg and go back to regedit. In there you need to grant back ownership to the original owners.
    In this case one Hive Key was owned by "SYSTEM" the other by "TrustedInstaller" (type: NT SERVICE\TrustedInstaller)

    I don't remember exactly which was owned by whom so you need to remember what's what.

    Lastly I am unable to find any Appid such as "runTimeBroker" with the key of F72671A9-012C-4725-9D2F-2A4D32D65169.
    The Appid is the hive key in this case. Nothing to do with runtimebroker.

    Cheers,
      My System SpecsSystem Spec

  3.    3 Weeks Ago #3

    Many thanks, yr advice on how to change permissions was the key to this - issue no longer occurs.

    You're a star!
      My System SpecsSystem Spec


  4. Joined : Oct 2015
    Posts : 1,205
    Windows 10 Pro X64
       3 Weeks Ago #4

    Hi,

    You're welcome.

    Cheers,
      My System SpecsSystem Spec


  5. Joined : Nov 2016
    Posts : 1
    Windows 10 (and older)
       3 Weeks Ago #5

    Hey fdegrove - thanks, it worked !!

    Had the precisely same log message. Just red your instruction.
    But for the first, I only changed the owner/permission of the {F72671A9-012C-4725-9D2F-2A4D32D65169} object in registry and then completely followed your further instructions (modifying with dcomcnfg).

    PC rebooted and checked Event-Log: No error anymore!
    So it seems not nessesary to modify ownership/permission of the {8D8F4F83-3594-4F07-8369-FC3C3CAE4919} object in registry also.

    Little hint for others: In dcom you have to scroll very down until come to the region with the numberleading entries.

    I'm happy to have a system now without any error messages.

    Thank you very much!
      My System SpecsSystem Spec


  6. Joined : Oct 2015
    Posts : 1,205
    Windows 10 Pro X64
       3 Weeks Ago #6

    Hi,

    So it seems not nessesary to modify ownership/permission of the {8D8F4F83-3594-4F07-8369-FC3C3CAE4919} object in registry also.
    That is possible since that hive key is owned by "System" and not the usual "TrustedInstaller".

    Glad to hear it worked for you.

    Cheers,
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Permissions error (CLSID/APPID) since Anniversary Update
Hi guys. I am seeing this error twice on every boot since upgrading (even a clean install doesn't clear it). Log Name: System Source: Microsoft-Windows-DistributedCOM Date: 04/08/2016 02:03:45 Event ID: 10016 Task...
User Accounts and Family Safety
Solved DCOM error 10016
I'm told this is a rather common error after upgrading from Windows 7 to Windows 10, but I have read many posts and suggested solutions, but I still get the error in the System Event Log when starting up. I suppose I could ignore it, as there does...
Performance & Maintenance
Solved Metro games crash immediately with DCOM timeout error - with AzureAD
hi, i've read dozens of threads here and elsewhere where windows 10 users have lost their start menu, lost their store app, lost the ability to open all store apps, or lost cortana. these all seem to stem from the 1511 update. i am familiar with...
Gaming
Some Windows 10 apps not working with DCOM error
Hello, I have been having this problem for a while now. There are some apps not working on a W10 Pro install, specifically: Microsoft Finance app ...
Software and Apps
Continuing DCOM event viewer error
I recently started getting this error in event viewer. There are a number of threads across the web about it, but none of them has presented the solution. The error is related to Runtimebroker.exe. Any new ideas? The application-specific...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:12.
Find Us
Twitter Facebook Google+



Windows 10 Forums