Hi all,

I am having a very annoying issue and hoping someone can help me out here. I am running Windows 10 on an HP Spectre x360 laptop. I have a clean install of Win10 (and actually did a clean re-install when I started noticing this issue in case I was dealing with any OS corruption...but it made no difference.

The issue is when I connect external drives with large files. I am using a USB 3.0 1tb Seagate BackupPlus drive (and I purchased a brand new one to rule out a drive issue). I am also using a USB 3.0 Lexar 256gb flash drive which also experiences the same issue.

The Seagate BackupPlus drive is Mac formatted (I use Mac Drive 10 to read/write) and the Lexar flash drive is Ex-FAT formatted.

I work in television and have to shuttle around show files, which are usually around 90-100gb video files. When I connect the drive containing the large files to the drive and then access the drive, the system hangs. The mouse won't move (it actually darts around the screen every few seconds or so when I move the mouse) and the system won't respond, although it doesn't say that anything is not running. I cannot CTRL-ALT-DEL or do anything else while the system is "thinking." If I wait several minutes (around 3-5 minutes), the system then goes right back to normal and then I can use it again, although it may hang again if I am still accessing the drives with large files. I have another Seagate USB 3.0 drive that is always connected via a dock - that drive does not contain large files and never experiences this problem. (That drive is NTFS formatted). I also don't have any issue with these other drives when connecting them to other systems to copy the large files onto them.

When the system hangs, if I disconnect the drive, it doesn't seem to make the system recover any faster - it still takes several minutes and then returns to normal.

I have noticed, though, that if File Explorer isn't open and I am not accessing the drive via any other programs, the system seems to work normally. It is only when I am accessing the drive via File Explorer or other programs I use to analyze or upload these files that I experience this hang.

Anyone have any suggestions on what I can do to either diagnose or solve this problem? It gets very frustrating because I am using the computer for my work and having to wait many minutes for the system to respond is a problem.

Thank you in advance!!