1.    30 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 2
    Windows 7 Ultimate

    Garmin devices in device manager but not showing in explorer.

    I upgraded to Windows 10 yesterday and everything works fine apart from this.
    I have Garmin edge 510 and 200 cycle computers, when plugged into the computer they are seen by windows and show up in device manager under disk drives. (as they should) However they do not show up in explorer and do not launch the options dialogue (play video, open in explorer, view photos etc.) Garmin express doesn't see either device either so I am unable to upload to Garmin's website. I thought it might have been an issue with the USB ports but I have tried four other devices and they all behave as they should and are fully seen/accessible via explorer.
    I have scoured the Garmin forums and no-one else seems to have this issue. I also had exactly the same issue when running the insider preview of Windows 10 so went back to Windows 7 thinking it was just a compatibility issue. I have the latest version of the express software and the same with the USB drivers so am at a loss as to what else to try!!!
      My System SpecsSystem Spec

  2.    04 Aug 2015 #2
    Join Date : Aug 2015
    Posts : 1
    Windows 10 Pro

    Hi, I'm having exactly the same problem after upgrading to Windows 10 Pro. I'm trying to connect to my Garmin Edge 810. I have the latest Garmin USB drivers. The Garmin connects to the PC, I can see both the device and the micro-SD card in windows explorer, however Mapsource and Basecamp don't seem to find the device.

    Also the garmin communicator plugin in firefox doesn't find the device. (I have installed the plugin for internet explorer, but since then internet explorer crashes every time when opening).

    I also don't have any clue at what to do next...
      My System SpecsSystem Spec

  3.    04 Aug 2015 #3
    Join Date : Jul 2015
    Posts : 2
    Windows 7 Ultimate

    I fixed it myself.

    I ended up manually assigning a drive letter to my 510 and everything now works as it should!!
      My System SpecsSystem Spec


Similar Threads
Thread Forum
Solved Unknown USB Device (device descriptor request failed)
Fresh install of Windows 10 and the last driver I need to sort out is the above. I believe it is my powered USB 3 hub to which I plug in my keyboard and mouse. Technically it is working but I don't like seeing yellow triangles on devices. So...
Drivers and Hardware
Upgraded from Windows 8 - elantech touchpad not even in Device Manager
Greetings, I have an Acer Aspire E 17 - ES1-711-P1UV When I updated my OS from Windows 8 to Windows 10 I noticed that the touchpad stopped working. I connected a USB mouse to the Laptop and that allowed me to have mouse functionality. I...
Drivers and Hardware
Device Manager - Copy and Paste Information
Is there any chance that the Device Manager in Win 10 allows the user to copy and paste information like Driver File Details when troubleshooting? In my experience Windows has often displayed 'help information' or 'error messages' that can only be...
General Support
build 10166 device manager
Have a look at the new mmc snap-in manager, right click view customise NICE Roy
Drivers and Hardware
Showing System Reserved Partition in File Explorer?
Hi For some reason Windows 10 is showing the System Reserved partition from Windows 8 in the File Explorer window. It never did this before. See Drive D:\ http://www.tenforums.com/attachment.php?attachmentid=5674&stc=1
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:31.
Find Us
Twitter Facebook Google+

Windows 10 Forums