1. Joined : Apr 2016
    Posts : 3
    Windows 10 Pro (64-bit)
       3 Weeks Ago #1

    No audio: Sound Blaster PCI Express X-Fi Titanium Build 14393.447?


    My Creative Sound Blaster PCI Express X-Fi Titanium worked just fine with Win 10 (64-bit) prior to the so-called "Anniversary Update" Any solutions would be appreciated.
      My System SpecsSystem Spec


  2. Joined : Jan 2014
    Inverness
    Posts : 619
    Win 10
       3 Weeks Ago #2

    "Refresh" the Soundblaster. Go to the Device Manager, uninstall the SoundBlaster, but DO NOT uninstall the drivers. Restart the PC and when Windows starts it will detect and reinstall it. This fixes a lot of problems and hopefully will take care of yours.
      My System SpecsSystem Spec


  3. Joined : Apr 2016
    Posts : 3
    Windows 10 Pro (64-bit)
       3 Weeks Ago #3

    Thanks, I'll give it a try!
      My System SpecsSystem Spec


  4. Joined : Jan 2014
    Inverness
    Posts : 619
    Win 10
       3 Weeks Ago #4

    One other thought. If the integrated (on the motherboard) audio got activated by the update, that may be set as the Default audio playback device rather than the SoundBlaster. As you are using a separate sound card, best option is to disable the integrated audio in the BIOS to avoid any potential conflicts.
      My System SpecsSystem Spec


  5. Joined : Apr 2016
    Posts : 3
    Windows 10 Pro (64-bit)
       3 Weeks Ago #5

    Noted. Thanks! (I am away from the PC concerned at present, so will only get around to "the fix" early in the new week),
      My System SpecsSystem Spec

  6.    3 Weeks Ago #6

    Sometimes Windows updates overwrites .dll files which your SoundBlaster card may use which may of unlinked it to the Soundcard stopping it from working, so make sure you have the latest SoundBlaster drivers & uninstall what you have then re-install the latest Soundblaster drivers.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Sound Blaster X-Fi Surround 5.1 Pro - default Win sound indicator?
Hi, I just bought this sound card and installed drivers for Windows 10. (and a crapton of bloatware with UI of Win XP media player...) Everything works well except one thing: when I change the sound (or mute) I don't see Windows 10 volume bar. I...
Drivers and Hardware
Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium
Hello -- After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and...
Drivers and Hardware
sound blaster on build 10240
I cannot get my surround 5.1 audio to work with this most recent build of 10240; and i cannot get into the enhancements that are supposed to be available for my card which is the x-fi titanium pci express sound card from creative. Is there any way...
Drivers and Hardware
Solved sound blaster in build 10166
I can not get my sound blaster x-fi titanium pci express sound card to give me sound through the right channels even though Ive uninstalled the support pack for 5.1 surround audio that was compiled from another sb user that did work in the last...
Drivers and Hardware
Solved No audio with PCI Express X-Fi Titanium
Build 10122 In previous builds, I always had audio from my PCI Express X-Fi Titanium sound card but after upgrading from 10074, I have no audio. I've tried reinstalling the drivers. I verified that if I switch over to my HDTV that there is audio....
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:11.
Find Us
Twitter Facebook Google+



Windows 10 Forums