Page 1 of 2 12 LastLast

  1. Joined : Oct 2016
    Posts : 9
    Windows 10 Home x64
       4 Weeks Ago #1

    WD Caviar Green in external enclosure only functional in USB 2 ports


    Hello all

    I recently sold my stationary, but decided to keep my internal hard drives and turn them into externals so that I would be able to use them with my laptop for backup and long-term storage.

    I ended up buying two Raidsonic Icy Box IB-373: IB-373U3

    My hard drives are 2TB and 4TB, both Western Digital Caviar Green.

    Now, when I plug the 4TB drive into either of the two enclosures, it works perfectly fine in my USB 2 port, but when I plug it into my USB 3 ports it is extremely slow, and often times out, when I try to copy anything to it. It usually transfers a few MB's and then stalls, and then transfers again, until at some point it times out. I can easily watch videos that I have on it though.

    I have tested my USB 3 ports using another USB 3 enabled external drive and it worked perfectly fine and achieved expectable speeds, so I know my ports and my laptop are not at fault.

    My question is whether this could be a problem with my hard drives? It seems unlikely that both the enclosures would be faulty, but it could be. Sadly I cannot test my 2TB drive before I have backed everything up on it, but I will be doing so shortly and then testing it. Until then, any help or tips is greatly appreciated.

    Edit: the other external I tested with was a 2.5" kingston SSD in an external enclosure that followed when I bought it.

    I just remembered now that the first time I plugged my 4TB external into one of the USB 3 ports it worked fine, although at USB 2 speeds. I have not been able to replicate this since.
      My System SpecsSystem Spec


  2. Joined : Jul 2015
    Posts : 6,355
    Windows 10 Pro
       3 Weeks Ago #2

    I don't have a solution, but I can tell you I have the same problem with an external enclosure. I think it has something to do with the UASP support.
      My System SpecsSystem Spec


  3. Joined : Oct 2016
    Posts : 9
    Windows 10 Home x64
       3 Weeks Ago #3

    I have now fixed the 2TB drive and tested it, and the result is the exact same. Times out on the USB3 ports when transferring files, but otherwise works fine. No problems in USB2 ports.

    NavyLCDR said: View Post
    I don't have a solution, but I can tell you I have the same problem with an external enclosure. I think it has something to do with the UASP support.
    So if I get the money back for these and buy 2 without UASP support, they should work just fine?
    I have been googling around but I can't find anyone with a similar problem. A lot of people with drives not showing up, but none where only copying/cutting are affected.
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 6,355
    Windows 10 Pro
       3 Weeks Ago #4

    Ulverbeast said: View Post
    So if I get the money back for these and buy 2 without UASP support, they should work just fine?
    I have been googling around but I can't find anyone with a similar problem. A lot of people with drives not showing up, but none where only copying/cutting are affected.
    Can't say for sure, but I can tell you that my older USB enclosures (including USB3) enclosures that do not have UASP support work just fine.
      My System SpecsSystem Spec


  5. Joined : Oct 2016
    Posts : 9
    Windows 10 Home x64
       3 Weeks Ago #5

    NavyLCDR said: View Post
    Can't say for sure, but I can tell you that my older USB enclosures (including USB3) enclosures that do not have UASP support work just fine.
    Just tried updating my chipset and booting up the computer with the external plugged in and turned on, still no dice. I will try swapping them in for some USB3 non-UASP externals, hopefully that'll solve the issue.

    Thanks!
      My System SpecsSystem Spec


  6. Joined : Oct 2015
    Posts : 1,205
    Windows 10 Pro X64
       3 Weeks Ago #6

    Hi,

    When the drive is plugged into a USB 3.0 port do you see a ''USB attached SCSI (UAS) mass storage device entry in "Storage Controllers, Device Manager ?

    According to the manufacturer:

    The fast USB 3.0 port with UASP support allows data transfer rates of up to 5 Gbit/s and ensures that even large amounts of data can be transferred quickly and without problems. The enclosure supports SATA I/II/III up to 6 Gbit/s and can therefore fully use the USB 3.0 standard.
    Cheers,
      My System SpecsSystem Spec

  7.    3 Weeks Ago #7

    Somebody has recently tracked down issues with the IcyDock 4-drive enclosures to similar sounding UASP problems. Check out this thread: Lost access to drive - - Windows 10 Forums. You may also find it worthwhile to contact the OP, because he's been researching UASP stuff recently.
    HTH,
    --Ed--
      My System SpecsSystem Spec


  8. Joined : Oct 2016
    Posts : 9
    Windows 10 Home x64
       3 Weeks Ago #8

    fdegrove said: View Post
    Hi,

    When the drive is plugged into a USB 3.0 port do you see a ''USB attached SCSI (UAS) mass storage device entry in "Storage Controllers, Device Manager ?
    Yes, when it is plugged in I see this entry.
    I just tested the drive on another computer and it works fine with high speeds there, so it definitely seems to be an issue with my computer, maybe the drivers.
      My System SpecsSystem Spec


  9. Joined : Oct 2015
    Posts : 1,205
    Windows 10 Pro X64
       3 Weeks Ago #9

    Hi,

    I just tested the drive on another computer and it works fine with high speeds there, so it definitely seems to be an issue with my computer, maybe the drivers.
    Quite possibly. Can you check if these are different compared to the machine that works OK with the drives ?

    Cheers,
      My System SpecsSystem Spec


  10. Joined : Oct 2016
    Posts : 9
    Windows 10 Home x64
       3 Weeks Ago #10

    fdegrove said: View Post
    Hi,



    Quite possibly. Can you check if these are different compared to the machine that works OK with the drives ?

    Cheers,
    I would love to, but as I understand it USB 3 and UASP are both supposed to be natively supported by Windows 10. I can try plugging in the drives to both computers and see in Device Manager whether there is a difference in drivers/versions that they run off, but other than that I am stumped as to how to research this further. Any ideas?
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Looking for a 4-bay USB 3.0 external HDD enclosure
I'm having a major issue with my current external hard drive enclosures (standard mechanic drives) that I'm trying to resolve in another thread so I won't go into that here: ...
Drivers and Hardware
HDD not working with Enclosure
I had an old laptop that wouldn't boot, so someone replaced my HDD and gave me the bad one back. They didn't explain what was wrong with it. A few months ago I bought and enclosure (ORICO 2588US3) to use the HDD with my current PC running...
Drivers and Hardware
More storage - NAS or enclosure via USB
Hi there I'm needing more HDD storage. Can't decide whether dedicated NAS storage -- expensive -- even 2 bay (empty no HDD supplied) costs around 150 - 200 USD or use a much cheaper external storage box with SATA/ USB3 connectors. I have 2...
General Support
Solved Boot setup from virtual DVD: Zalman ZM-VE200 enclosure
For years I've been using this rebranded iodd enclosure, USB 2.0, which can create hardware-based virtual optical drives from ISOs and various other disk image formats. Under Windows 10 I've been using it so far for upgrade installs. This week I...
Installation and Setup
Whats the best 2.5" HDD enclosure i can get for about 20$?
ok so my new HDD western digital enclosure fell once with the wire in it and the port broke off:mad: i thought that western digital are top brand, enclosures included. so im looking for a sturdy new hard drive enclosure that i can put my 2.5"...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:01.
Find Us
Twitter Facebook Google+



Windows 10 Forums