1.    2 Weeks Ago #1
    Join Date : Oct 2016
    Posts : 1
    Windows 10 64Bit

    FIXED: Realtek6.0.1.7945: DoblyDigitalLive+SPDIF; Only Stereo in Games


    I found a fix, you can use the xaudio patcher from here and enjoy 5.1 in games again:

    XAudio2 Dolby Digital Live patcher defer time.Sleep()

    I remembered a problem I had with Alien Isolation under Windows 7 or 8, I also only got stereo sound instead of surround in this game (every other game worked fine).

    Sadly, I don't know who provided the original fix, but I still found a thread (with many dead links) and a dropbox link for the files:

    Thread: Fix for no surround sound in Alien Isolation, no 5.1? Realtek audio card? Fix here. :: Alien: Isolation General Discussions
    Files: DTS_DDL_surround_FIX.zip - Google Drive

    From what I read it doesn't work in WatchDogs and FarCry4 (no problem for me, I stopped buying Ubisoft Games anyway).


    Downloaded a new Win10 ISO from Microsoft, now I got the problem everyone seems to have, I only get stereo sound in games instead of 5.1.....


    I've got a problem with DolbyDigitalLive over SPDIF:

    Clean Windows10 installation, i installed UpdatePack September 2016, after that i installed the newest Realtek Driver (

    In the Realtek HD Audio Manager i set the "Digital Output (Optical)" as "Default Device", changed the "Default Format" to "Dolby Digital Live (5.1 Surround)".

    When i open the "Supported Formats" of "Realtek Digital Output (Optical)" in controlpanel>sound>"Realtek Digital Output (Optical)"properties, select Dolby Digital, "Test", i can hear the Testsound on all speaker (Sub, FrontLeft, Center, FrontRight, BackRight, BackLeft).

    When i switch to the Advanced Tab, "Default Format" "Dolby Digital Live (5.1 Surround)", "Test", i get the Error Message "Failed to play test tone."

    Gigabyte P67A-UD4-B3 with Realtek ALC889+DolbyDigitalLive and Onkyo TX-SR307 conncted via SPDIF

    TLDR: DolbyDigitalLive 5.1 no sound, Stereo working, why?

    Hope someone can help me, i have this issue since the release of Win10, switched back to Win7 because of this and because many others had problem with 5.1 over spdif, but i thought this would be fixed by now?

    Regards Tom

    Click image for larger version. 

Name:	DDL.jpg 
Views:	3 
Size:	265.4 KB 
ID:	104840
    Last edited by TheMCP; 2 Weeks Ago at 16:34. Reason: FIXED
      My System SpecsSystem Spec

  2.    2 Weeks Ago #2
    Join Date : Jan 2014
    Posts : 567
    Win 7/10

    If you downloaded a new ISO, check the Device Manager, Sound section, to see if you still have Realtek listed or if you only have "High Definition Audio" listed. If its High Defintion Audio, that is the generic, basic function, Windows installed sound driver. Reinstall the Realtek and see if that helps.
      My System SpecsSystem Spec


Similar Threads
Thread Forum
Realtek HD audio non sound after win 10 upgrade
So I just installed windows 10 on my Asus N55SL (previously running windows 7), for the most part it works great however I am having trouble getting sound to play. I have tried installing the latest realtek HD audio drivers but thishas not helped at...
Drivers and Hardware
RealTek HD sound problem
Hello, I've been installing the latest drivers from realtek audio, both from Reaktek website and automatic updates. Whenever I install it the sound is bugged. I hear trash noise and the volume is super low. I have to revert back to the windows 10...
Drivers and Hardware
WMP and Edge can't play popular format type of sound and video
I don't know why but this is happen to my PC, seem like WMP and Edge can't not play mp3 and mp4 as normal, it just lag, but they can play both flv and vob very well. How can I fix it ?
General Support
Solved No audio on headset. But sound test O.K.
Since upgrading to Windows 10, 64-bit, I have no audio on the headset. Also, speakers are not muted when headset is plugged in. Headset checks out O.K. on sound test. HP Pavillion 500-249 Desktop.
Drivers and Hardware
New Upgrade Realtek 5.1 Driver Sound Issues
Hello I finally got my copy of Win 10 but I'm having problems with my 5.1 speakers when I first upgraded there was no sound at all then I re-installed realtek_hd_audio_6.0.1.7464 drivers and I have sound but only from main speakers. Rear speakers do...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:10.
Find Us
Twitter Facebook Google+

Windows 10 Forums