Page 9 of 56 FirstFirst ... 789101119 ... LastLast

  1. Joined : Sep 2015
    Posts : 97
    Dual boot: Win 10 Home; Win 8.1 Pro
       16 Sep 2015 #81

    Cliff S said: View Post
    Sorry, did you mean me? I have 840 Pros and I have version 4.7 on both machines. See my post here. If you meant another Cliff, oooops then.
    No, no. You're the Cliff I meant.

    Thank you.

    I just bought a 850 EVO. Planning to mess with it over the weekend, and taken in aggregate across this thread your posts seem like the most reasonable way forward . So just wanted to clarify.

    Your recommendation is to use Magician 4.7, but to use Windows for performance optimization and forget about RAPID?

    Sounds good. Thank you.
      My System SpecsSystem Spec


  2. Joined : Feb 2015
    Bamberg Germany
    Posts : 13,396
    Microsoft Windows 10 Pro 64-bit 14393 Multiprocessor Free
       16 Sep 2015 #82

    PlatypusKnight said: View Post
    Your recommendation is to use Magician 4.7, but to use Windows for performance optimization and forget about RAPID?

    Sounds good. Thank you.
    For now yes, later if they make RAPID available to Win10, then I feel it's a user choice. The thing is now that I've been "forced!" to go without it,, I haven't noticed a difference in day to day use. Basically after I clean installed on my SSD, I ran winsat formal in an admin command prompt, let it finish, rebooted and let Windows take care of all the settings(prefetch & superfetch, indexing and other things). I now have Magician basically for "Firmware"updates only, not gimmics.
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 265
    Windows 10
       16 Sep 2015 #83

    +1 to Cliff S
      My System SpecsSystem Spec


  4. Joined : Sep 2015
    Posts : 1
    Windows 10 Pro
       17 Sep 2015 #84

    I recently upgraded my computer as per my profile, and it already screams along. I can't wait to see what it will do when Samsung gets the chit together and makes RAPID Win10 compatible.
      My System SpecsSystem Spec


  5. Joined : Sep 2015
    Posts : 97
    Dual boot: Win 10 Home; Win 8.1 Pro
       19 Sep 2015 #85

    I installed the 850 EVO relatively painlessly. I have pretty good read and write speeds, but I am concerned that it says I do not have ACHI enabled.

    What gives?
      My System SpecsSystem Spec

  6.    19 Sep 2015 #86

    PlatypusKnight said: View Post
    I installed the 850 EVO relatively painlessly. I have pretty good read and write speeds, but I am concerned that it says I do not have ACHI enabled.

    What gives?
    I have the same SSD and Magician tells me the same even the bios says I have ACHI enabled, but computers says no.
      My System SpecsSystem Spec


  7. Joined : May 2015
    Posts : 11
    Windows 10 Pro
       23 Sep 2015 #87

    FWIW ... S-M changed its status message this morning from "You have the latest version" to "Connect to the internet to upgrade to the latest version" .. another muck up ? I AM connected .. all the time !
    Their support site still carries version 4.7 ... ???
      My System SpecsSystem Spec


  8. Joined : Sep 2015
    Posts : 97
    Dual boot: Win 10 Home; Win 8.1 Pro
       27 Sep 2015 #88

    Rigel said: View Post
    FWIW ... S-M changed its status message this morning from "You have the latest version" to "Connect to the internet to upgrade to the latest version" .. another muck up ? I AM connected .. all the time !
    Their support site still carries version 4.7 ... ???
    I am also seeing that now.
      My System SpecsSystem Spec


  9. Joined : Aug 2015
    Penn's Woods
    Posts : 1,177
    Windows 10 Home RTM + Insider
       27 Sep 2015 #89

    PlatypusKnight said: View Post
    I am also seeing that now.
    I just picked up a firmware update for my 850 EVO the other day via SM, posted about it in another thread. Could it be that you guys are being alerted to, rather than an SM update?
      My System SpecsSystem Spec


  10. Joined : Mar 2014
    Posts : 71
    Windows 10, 64 bit
       27 Sep 2015 #90

    I have the 840 Pro and I got the same message (only one time) several days ago.
      My System SpecsSystem Spec


 
Page 9 of 56 FirstFirst ... 789101119 ... LastLast


Similar Threads
Thread Forum
Solved Samsung 850 Pro SSD Software Support for WIN 10
I have Win 10 (10240) installed and a new Samsung 850 Pro SSD to install. The current versions of the Samsung supplied software, Magician 4.6 (I downloaded this because the one supplied with the SSD wasn't the current one) and Data Migration 2.7...
Drivers and Hardware
Calling all Samsung owners
There seems to be an issue with a raft of different Samsung computer products being unable to install Win 10 TP. The issue is exactly the same for all being locked out after 3 seconds at the logo screen trying to install with either USB or DVD...
Installation and Setup
RAPIDmode, Samsung SDD & Win10...how ?
I just installed a Samsung 850pro SSD in my Lenovo laptop & one of the features in its Magician 4.5 software is RAPIDmode . Sort of a ram caching frequently used I/O processes to add some quickness. Anyhow, it lists the requirements --...
Drivers and Hardware
Samsung NP-RV509-A0CIN Problem With 4 GB RAM
Recently I have purchased a HP 4 GB RAM DDR3 1333MHz for my Laptop Samsung NP-RV509-A0CIN. After installing this RAM into my laptop. My laptop show the 4 GB on system BIOS but it is not booting windows or anything just a black screen. So I...
Drivers and Hardware
Samsung Updates ?
Has anyone connected a Samsung phone to their Windows 10 computer. Friday I connected my Samsung Galaxy 3 phone to my computer to download some pictures to my computer. Since then I have received 5 updates for my phone and all of them say they were...
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36.
Find Us
Twitter Facebook Google+



Windows 10 Forums