1.    03 May 2015 #1

    Printers working fine until update to 10074

    I had two printers hooked up in wireless mode, a Samsung ML-2525W and a Brother inkjet MFC_J870DW. Both were working fine until the recent update and both dropped off the network.
    I reinstalled the driver for the Samsung and providing I have it wired to a USB port on the computer it works fine, I tried my usual method I have written down to reconnect wireless but to no avail. It is odd but it shows up in the router as it is connected but when I go through the connect routine it reports "not connected"
    I havnt tried the Brother printer yet.
    Its odd.
      My System SpecsSystem Spec

  2.    04 May 2015 #2
    Join Date : Jul 2014
    San Jose, California
    Posts : 1,871
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
      My System SpecsSystem Spec

  3.    04 May 2015 #3

    After a nights sleep and a few reboots both printers are now back online.
      My System SpecsSystem Spec

  4.    18 May 2015 #4
    Join Date : Oct 2014
    Polk County Texas USA
    Posts : 9,919
    Windows 10 Insider Preview

    Tacit, I don't know about the Samsung, but "Run as Administrator" is your friend when installing your MFC-J8xxDW printer as wireless.
      My System SpecsSystem Spec

  5.    18 May 2015 #5

      My System SpecsSystem Spec


Similar Threads
Thread Forum
No update available in 10074
So I had alot of problems on the builds coming out after 10074 and decided to stay on this build untuil today. Saw the new release and thought it was about time to get some updates, but no matter how I try, Windows always say I got the lastest...
Windows Updates and Activation
Solved IE11 Not working in Build 10074
Hello! I recently updated to build 10074 and IE11 will not launch at all! It is set as my default browser. Spartan (Edge) is working just fine...but I dont want to use it just yet as it doesnt store cookies and autofills logins. (among other...
Browsers and Email
Preview 10074 - Windows Startup icon not working
Just updated from 10049 to 10074 Windows startup icon (lower left on toolbar) not working. Can only rt click to see basic listing.:mad:
Software and Apps
Build 10074 not working as should
hi guys, my network and/or homegroup no longer work. After searching and trying to fix this (a couple of hours) i gave up, gave feedback to MS and returnde to Build 10061. Hate to do a fresh install, although i have burned the ISO. So i...
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:33.
Find Us
Twitter Facebook Google+

Windows 10 Forums