Hello everyone,

I have encountered a problem with Samsung 950 PRO 512GB M.2 NVMe. I would appreciate your help as my knowledge in hardware and software is minimal. So thank you in advance.

I have just finished installing windows 10 in a new pc while using old HDD drives I had from my older pc. I have purchased Samsung 950 PRO 512GB M.2 NVMe to be my boot drive and purchased the samsung 850 ssd for regular storage.

In addition to the above I already had 2 older HDDs from my previous pc that I connected them for extra storage.
When I started the windows 10 installation I chose custom so that I could choose the NVME ssd for installation and boot, however, I noticed that I couldn't differentiate between the two samsung ssds as both were 512 gb and windows only called each 'drive 1 or drive 2' and so on.

So, I randomly chose one and I think it appears to be the 850 that was installed, to my dismay.
Now the issue is that I cannot locate the NVME drive on 'this pc' although it is seen in BIOS for boot drive. To confuse me even more, in the BIOS I cannot see the M_1 slot when I go to advenced then storage in BIOS, the other 3 drives are located by their different satas.
I don't know what to do.
to summarise I would appreciate it if someone can help me in getting:
1 - the samsung 950 to be my installed windows, currently it says its the boot drive but i dont know if it needs to have windows installed on it
2 - to have the NVME recognised by windows so I can use it for storage and so on.

my mother board is ASROCK Z170 EXTREME 7+
cpu intel i7-6700k

Thank you so much for your kind help.