Hello everyone.

I'm having an issue with a brand new keyboard on my PC. I recently bought Gembird KB-UMGL-01 keyboard and I'm having an issue when holding down a button. For example, whenever I'm playing World of Warcraft if I hold down W to walk forward it acts as if I'm pressing the button repeatedly. It's not specific to just some buttons, I've tried rebinding move forward to random keys and holding them down, same thing happens. I have also tried connecting the keyboard to multiple different USB ports on my PC, and the problem still presists. However, when I tried it on my laptop (also running Windows 10 pro) there was no issue at all.

I have checked manufacturer website, there is no drivers for this specific keyboard. I also tried googling about it, but the only things I managed to find are about specific keys (CTRL, Win, Shift etc.) acting as if they are stuck and the manual also doesn't say anything about this.

I hope that someone here can help me solve this. Thanks in advance.