Page 3 of 3 FirstFirst 123
  1.    09 Feb 2016 #21
    Join Date : Jun 2015
    Posts : 3,004
    Windows 10 Pro 64 bit

    Quote Originally Posted by Buzzik View Post
    I can see my Crusial SSD (just storage) when connected to Marvell 6 or 7 port and it run at 6bg/s, but when I connect my Windows drive I cannot boot up PC


    I've just deleted Marvell Console Driver and now I have the same Standart SATA AHCI Controller and under storage no more Marvell. Non bootable drive still works at 6gb/s.
    Why I cant get my windows up on this damn Marvell, I am confused
    I used to run windows through Marvell on Windows 10 before i updated my BIOS to the latest version on clean windows install, there some additional options appeared Under Marvell controller in BIOS I don't have listed in my manual anymore - must have been changed with an update.

    I might just stick with Intel's, it takes like 15 more seconds to boot up with Marvell enabled in BIOS
    Yes they are both .exe files which i never recall seeing for this type of file. Usually they are number of files after the extraction of download and then can be installed through the device manager post windows install also. Usually done as a preinstall before Windows installs but can be done through Device Manager afterwards.

    Believe need the Marvell Console Driver in place, told you not to uninstall it afterwards. Never had a board that had 2 controllers and one being SATA 3 and other being SATA 2. I posted pictures of your manual showing it. BIOS updates usually improve support for hardware , sure Gigabyte would make sure drivers worked, but since seeing there is only support up to Windows 7.

    This was the correct one for that controller :
    Marvell RAID Preinstall Driver (SATA3) for AHCI Mode
    Note: Press F6 during Windows setup to read from floppy. 0.28 MB 2010/04/29

    Can always call Gigabyte, i have before when needing answers it is not a waste of time, they will help answer questions you have on this and if it can be down correctly or you can go back to Intel where there was no issues and sacrifice some speed lose for now.

    This is there number, select technical support on the prompt 1-626-854-9338
    Give them your board model GA-X58A-UD5 (rev. 2.0)
      My System SpecsSystem Spec

  2.    10 Feb 2016 #22
    Join Date : Dec 2015
    Posts : 13
    Windows 10 64

    You'll likely need to make some configuration changes overall. I'd try the following.

    I have the AMD variant of that board, and I can boot from the Marvell adapter
    You're going to have to completely reinstall windows 10, with 1 SSD ONLY connected to the Marvell controller port.

    Test 1:
    Shut the machine down
    Remove everything connected to ALL SATA ports
    Connect an SSD to the Marvell port ONLY
    Power on the machine
    Hit Del to get into BIOS
    See if the motherboard recognizes the drive in the drive table in BIOS
    If NO, then you may have a firmware/BIOS setting to change, OR it just won't be bootable.

    If it DOES recognize the drive in BIOS, then prepare to do a clean reinstall of Windows 10
    When you're doing the clean reinstall, you'll have a couple of possible outcomes.
    1) Windows 10 will load the storage class driver then automatically select the Marvell device driver, so when you select "install windows 10", it will automatically see that disk in the system.
    2) Windows will not see any disks, and will prompt you to "load storage controller driver" (I forget the exact words), in which case, you'll need the Marvell driver on a USB stick plugged into your system

    Download this driver (this guy posted a link to an Asus driver package for the Marvell Driver) Unpack it and move the contents to your USB stick, and navigate to the correct subdirectory where the INF file is, Windows should see it, and attempt to load the driver.

    If Windows see the driver, and loads the driver, then it will install on your Marvell SATA 3 connected SSD, and when the BIOS bootstrap handoff takes place afterwards, it will only see a MBR on that disk. It also may be worth trying to do this routine NOT in AHCI mode for the Marvell ports. AHCI has no real impact on performance,

    Sometimes, you need to trick the combo of BIOS, Windows bootloader, etc

    If Windows doesn't see the driver, then post what happens. If you get confused, post where you're getting stuck and I'll try to help

    In my case, it all worked fine, and Windows 10 loaded the controller driver by itself

    In reality, the difference between SATA 2 and 3 speeds on bootup isn't really that different, maybe a few seconds. But its worth a try
      My System SpecsSystem Spec

  3.    20 Mar 2016 #23
    Join Date : Oct 2014
    Posts : 37
    Windows 10 Enterprise x64

    Quote Originally Posted by AnonVendetta View Post
    I had this issue on my laptop as well. I have a Samsung 850 EVO that is SATA III-capable but runs at SATA II (i.e. HDD speeds). I fixed it with a modded BIOS.
    Modded BIOS? Meaning for your PC (if so, why?) or SSD firmware? Was there some further information about this somewhere that led you to do that?

    @ Buzzik: Did you ever figure it out?
      My System SpecsSystem Spec

  4.    20 Mar 2016 #24
    Join Date : Jan 2016
    Posts : 30
    Windows 10 Home

    Quote Originally Posted by rseiler View Post
    Modded BIOS? Meaning for your PC (if so, why?) or SSD firmware? Was there some further information about this somewhere that led you to do that?

    @ Buzzik: Did you ever figure it out?

    Nope. I didn't go for Windows reinstall since I already had all installed on my drive, and it's a pain in the ass doing it all over again.
    Please post back here if you have similar issue and find solution.
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123

Similar Threads
Thread Forum
Solved E-SATA Observations
Ok I think this is some valuable information that needs to be out there. As this is what I encountered with my machine. I don't know if all machines will do the same but this is what happened for me. Just my 2 cents worth.. :) A while ago...
Drivers and Hardware
ASM106x Sata Driver
Hello I have an ASUS Maximus VII Hero... It would seem ever since installing the Asmedia SATA Controller Driver V3.1.6.0 driver my 1 TB internal has issues.... as in it will be I quote from the event viewer "Disk 1 has been surprise removed" ...
Drivers and Hardware
Hot Plug a SATA DVD to help get it discovered?
General Support
Solved sata driver
Is there a newer sata driver for NM10 chipset (atom N455) netbooks or a way to install? Every driver from Intel and Samsung says this platform is not supported (tried running as W7 or W8) and the default one is old (2006) and buggy and getting ahci...
Drivers and Hardware
How do I install W10 to a SATA drive
When I download my free version of Windows 10, I want to install it to my 128gb SATA drive which is now labeled Drive S, and keep my current installation of Win 7 Ultimate on drive C in case I want to revert back to Win 7. How do I install Win 10...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:43.
Find Us
Twitter Facebook Google+

Windows 10 Forums