1.    02 Aug 2015 #1
    Join Date : Aug 2015
    Posts : 52
    Windows 10

    Edge definitely given the boot for time being

    Using Edge causes my network adapter to stop working and I lose the internet connection. Getting it back takes at least five minutes. Restarting windows then hangs on restart so I have to force a shutdown.

    Would report in windows feedback but it doesn't come up when I type it in the search menu.
      My System SpecsSystem Spec

  2.    02 Aug 2015 #2
    Join Date : Mar 2015
    Posts : 48
    Windows 10 & 8.1 & 7

    Edge is a fairly large program. Have you been able to replicate the issue under any other circumstances? Other browsers, other heavy network applications? Have you gone to the manufactures website to download any recent or new drivers? They may have new network drivers. Does it only happen in a certain website and not on others? Any other issues?
      My System SpecsSystem Spec

  3.    02 Aug 2015 #3
    Join Date : Aug 2015
    Posts : 52
    Windows 10

    Due to this and several other irritating problems but mainly that I lose my internet connection and it takes 10 minutes to sort during which time restart computer doesn't work, so its back to 8.1 for me.
      My System SpecsSystem Spec

  4.    17 Aug 2015 #4
    Join Date : Aug 2015
    Posts : 52
    Windows 10

    After computeractive magazine showed a way of setting the default browser I came back to 10 however it doesn't work at least for me. Also even using IE 11 I lose the internet connection from time to time, rebooting causes a hang on a screen saying restarting and it takes about 15 minutes to get connected again.
      My System SpecsSystem Spec


Similar Threads
Thread Forum
Boot Time with SSD and Win 10 is 90 sec.
I have an ASUS 6730 with Win 10 and I just installed an SSD as the boot drive. Boot time is very long 90 sec. I have the latest BIOS version. I tried disconnecting all external drives. I turned off the old internal drive in Devices just in case the...
Performance & Maintenance
Slow boot & shutdown time
10 doesn't seem to be booting very nicely. What I mean is that it seems to be having a difficult time initilizing my SSD, so upon boot I get a blank black screen for anywhere from 60-180 seconds, where the primary drive activity LED is inactive,...
General Support
Solved How to start an app at boot time?
I have a need to start an app ( e.g. notepad) as soon as a certain account is used to boot Windows 10. Can it be done and if so how?
Software and Apps
Unusually long boot time
I can't quite get a handle on this issue. Why would having USB drives attached to system increase boot time from 8 seconds to 110 seconds? Never happened on old 560 box, but does on new 3847. Dell says, "That's the way it is". Sounds odd....
Drivers and Hardware
Solved Boot time faster?
Hi there, a question to all the testers out there: Are boot times of Win 10 installed on an SSD faster than on 8.1? With and without fast startup....?! Thanx for anwering
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:30.
Find Us
Twitter Facebook Google+

Windows 10 Forums